Cannot install onto mpt-driven drive

Joe Marcus Clarke marcus at
Fri Aug 20 21:12:25 PDT 2004

On Fri, 2004-08-20 at 23:17, Joe Marcus Clarke wrote:
> I just got a new Dell Precision 360 workstation with an LSILogic SCSI
> controller:
> mpt0: <LSILogic 1030 Ultra4 Adapter> port 0xcd00-0xcdff mem
> 0xfe780000-0xfe79ffff,0xfe760000-0xfe77ffff irq 10 at device 3.0 on pci2
> mpt1: <LSILogic 1030 Ultra4 Adapter> port 0xce00-0xceff mem
> 0xfe7x0000-0xfe7dffff,0xfe7a0000-0xfe7bffff irq 9 at device 3.1 on pci2
> I'm trying to install 5.2.1-RELEASE on this machine, then upgrade it to
> RELENG_5.  The controller and 36 GB SCSI harddrive are detected just
> fine at boot time, but as soon as I go to write out my partitions to
> this drive, I get a timeout:
> mpt1: time out on request index = 0xfe sequence = 0x000001a0
> mpt: Status 00000001, Mask 00000001, Doorbell 24000000
> request state On Chip
> SCSI IO Request @ 0xcde1fc30
> 	Chain Offset 0x10
> 	Msg Flags 0x00
> 	MsgContext 0x000000fe
> 	Bus: 0
> 	TargetID 0
> 	SenseBufferLength 32
> 	LUN: 0x0
> 	Control 0x01000000 WRITE SIMPLEQ
> 	DataLength 0x00010000
> 	SenseBufferAddr 0x00391de0
> 	CDB[0:6] 0a 01 3a 65 80 00
> 	SE32 0xd6937c30: Addr=0x9aa7000 FlagsLength=0x14001000
> 	SE32 0xd6937c38: Addr=0xa128000 FlagsLength=0x94001000
> 	CE32 0xd6937c40: Addr=0x391c48 NxtChn0=0x16 Flags=0x30 Len=0x50
> 	SE32 0xd6937c48: Addr=0xaa69000 FlagsLength=0x14001000
> This trace continues for a while, but I'm transcribing it from the
> screen.  I can certainly do the entire thing if someone is interested. 
> I can even set someone up with serial console access if they'd like. 
> Also note: this same model controller and drive work in another Dell
> Precision machine under -STABLE.   I've tried booting 5.2.1 under normal
> sand safe modes with the same result.  I looked in CVS, and there didn't
> appear to be any relevant driver changes since 5.2.1-RELEASE.  Hoping
> someone can help me out.  Thanks.

Sorry to follow-up to myself, but it looks like this problem can be
fixed by the patch in  I saw the
original NetBSD PR that reported this:, and my
symptoms look the same.

I'll try and build a release with this patch to see if it does the
trick.  In the meantime, if someone could have a look at this PR, that
would be great.


> Joe
PGP Key :
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: This is a digitally signed message part
Url :

More information about the freebsd-current mailing list