Duplicate free of item %p from zone( Was: suspend/resume problems (APM) on Thinkpad T40)

Gleb Smirnoff glebius at freebsd.org
Wed Aug 11 03:46:54 PDT 2004

On Mon, Jul 26, 2004 at 05:28:42PM +0400, Gleb Smirnoff wrote:
T> On Mon, Jul 26, 2004 at 03:06:16PM +0200, Anders Odberg wrote:
T> A> I have a Thinkpad T40 (model 2373-94G) running FreeBSD-5-CURRENT. Until the
T> A> beginning of June, using APM to suspend/resume worked great on this
T> A> machine. On every cvsup I've tried after the beginning of June, suspend
T> A> seems to work fine, but when resuming, the machine will simply freeze.
T> A> I get my prompt back on the display, but no input is accepted, the machine
T> A> is completely dead, and needs to be power-cycled.

I have got a backtrace today:

(kgdb) bt
#0  doadump () at pcpu.h:159
#1  0xc054005a in boot (howto=260) at /usr/src/sys/kern/kern_shutdown.c:391
#2  0xc05403c8 in panic (fmt=0xc06ece45 "Duplicate free of item %p from zone %p(%s)\n")
    at /usr/src/sys/kern/kern_shutdown.c:553
#3  0xc0654914 in uma_dbg_free (zone=0xc1044c60, slab=0xc1ad8f70, item=0xc1ad84a4)
    at /usr/src/sys/vm/uma_dbg.c:276
#4  0xc06531b1 in uma_zfree_arg (zone=0xc1044c60, item=0xc1ad84a4, udata=0x0)
    at /usr/src/sys/vm/uma_core.c:2222
#5  0xc0504872 in g_destroy_bio (bp=0x0) at uma.h:302
#6  0xc0507e53 in g_std_done (bp=0x0) at /usr/src/sys/geom/geom_subr.c:752
#7  0xc05940a0 in biodone (bp=0xc1ad84a4) at /usr/src/sys/kern/vfs_bio.c:3002
#8  0xc048c9d2 in ad_done (request=0xc1723000) at /usr/src/sys/dev/ata/ata-disk.c:322
#9  0xc047bcbc in ata_completed (context=0xc1723000, dummy=0)
    at /usr/src/sys/dev/ata/ata-queue.c:404
#10 0xc047be0c in ata_timeout (request=0xc1723000) at /usr/src/sys/dev/ata/ata-queue.c:442
#11 0xc054e9e8 in softclock (dummy=0x0) at /usr/src/sys/kern/kern_timeout.c:255
#12 0xc0528722 in ithread_loop (arg=0xc14f4580) at /usr/src/sys/kern/kern_intr.c:546
#13 0xc0527786 in fork_exit (callout=0xc05285b0 <ithread_loop>, arg=0x0, frame=0x0)
    at /usr/src/sys/kern/kern_fork.c:819
#14 0xc0682ebc in fork_trampoline () at /usr/src/sys/i386/i386/exception.s:209

Afte resume I can move mouse in X for some time, type smth. And in a few seconds
panic. Hardware is Thinkpad T20.

Totus tuus, Glebius.

More information about the freebsd-current mailing list