cvsup on amd64 just broke today

Conrad J. Sabatier conrads at
Tue Aug 10 15:01:59 PDT 2004

On 10-Aug-2004 Doug White wrote:
> On Mon, 9 Aug 2004, Conrad J. Sabatier wrote:
>> > Can you run cvsup manually? It appears to be trying to execute a
>> > binary as a shell script here.
>> Tried that, got the same result.
>> I hadn't noticed it before, but it does strike me as odd that the
>> binary package for amd64 would include a file with "i386" in the
>> name, and which is, in fact, an ELF 32 binary.  Did something
>> change today that would effect the handling of such a file, perhaps?
> Possible.  In the interim you might try installing this native amd64
> version of cvsup (its a package so pkg_add it):
> If that doesn't work for you I can build a package on my amd64 box.

Thanks, it works.

I'm just wondering, if you're able to build the port under amd64, why
isn't it in the ports collection?

I'm also wondering if maybe the breakage of the earlier version I had
installed may have been related to the recent import of the new "file"

Conrad J. Sabatier <conrads at> -- "In Unix veritas"

More information about the freebsd-current mailing list