ACPI autoload failed: no such file or directory

Martin MATO martin.mato at
Tue Aug 10 08:05:32 PDT 2004

Martin MATO a écrit :

> Martin MATO a écrit :
>> John-Mark Gurney a écrit :
>>> Martin MATO wrote this message on Tue, Aug 10, 2004 at 04:43 +0200:
>>>> anyone could explain this.. strange thing?
>>> Someone else is seeing this w/ pf...
>>> Do you have any lines modifing module_path in your loader.conf?  Also,
>>> do you have an upto date support.4th?
>> i haven't any lines modifying  module_path ( Andrew Milton has mailed 
>> me about   adding module_path="/boot/kernel /boot/modules" to 
>> /boot/loader.conf, should fix it; but has no effects.)
>> and i have an up to date  support.4th , compiled at the same time as 
>> the  kernel files.
>> booting whith the GENERIC kernel has same behaviour, but with other 
>> errors messages; not in relation whith  acpi; but debug support  (!)
>> i'll try compiling one whitout any  OPTFLAGS and CFLAGS 
>> optimization,  to see... (i use -O2 -pipe)
>> but i doubt it is in relation with the kldload behaviour...
>> ps: sorry for my bad english, i'm french...
>> _______________________________________________
>> freebsd-current at mailing list
>> To unsubscribe, send any mail to 
>> "freebsd-current-unsubscribe at"
> Well, with a GENERIC kernel first, and a new world compiled without 
> the -O2 flag, i obtaint the same problem. both with acpi autoload AND 
> kldload error..
> i'm out of ideas...   :P
> _______________________________________________
> freebsd-current at mailing list
> To unsubscribe, send any mail to 
> "freebsd-current-unsubscribe at"
well,  i tried now some kload  "modules.ko"  NONE worked (no such files 
or directory) kldload doesn't seems to find them
i checked the modules path;  and i  added  - again-   
module_path="/boot/kernel /boot/modules"  in /boot/loader.conf

after reboot and the same  ACPI autoload error message,
kldload doesn't find again none of the modules i tried to load (i tried 
a lot of them)!
the module path in the sysctl variable is effectively set to  
"/boot/kernel /boot/modules"

with a
cp /boot/kernel/*.ko /boot/modules 
kldload find finally the modules files; EXCEPT acpi.ko.  
i repeat I KNOW  that acpi.ko can't be loaded from userland,  i 'm only  
seeing if kldload find the file(s) specified.

well i think   i have a big problem here...  :°(

More information about the freebsd-current mailing list