slice weirdness

Stijn Hoop stijn at
Mon Aug 9 00:52:32 PDT 2004

On Mon, Aug 09, 2004 at 03:47:32AM -0400, Allan Fields wrote:
> On Sun, Aug 08, 2004 at 11:13:37PM +0200, Stijn Hoop wrote:
> > while trying to migrate my FreeBSD -CURRENT partition to another disk,
> > I keep running into a slice weirdness issue which makes the kernel unable
> > to find it's root fs. It seems that something about the partition table
> > is fishy such that GEOM doesn't find both slices:
> Which kernel: the one from your existing install, the install kernel
> (booting off CD), a new kernel?

The same kernel that boots my current installation; I just did a new
'make install{world,kernel} DESTDIR=/mnt/NEW' where /mnt/NEW is the mounted
/dev/ad2s1a (ie the new slice after just having it partitioned).

> I've had some partition/slice issues in the past w/ install CD and
> missing device entries with non-standard slice (anything except s1
> entry), can't recall details, but running sysinstall w/ newfs
> flag to N creates appropriate entries.  Else I've found suitable
> device entries elsewhere or make them temporarily with mknod.
> Maybe this was only an issue in -stable.

I don't know, but obviously I can't mknod / do something about it when
the kernel has just been booted.

> > So where's my /dev/ad1s2?
> > 
> > The disk layout is ad1s1 is my Windows partition, ad1s2 my targeted new
> > partition for the FreeBSD installation currently residing at ad0s1.
> Out of curiosity, did you disklabel the second slice anew or just
> copy/dd existing slice over to new drive?

I disklabeled anew.

> > I first created ad1s2 by hand using fdisk, but got the exact same result.
> But, does a newly created slice/disklabel/root filesystem have the same
> problem?
> i.e. if you were to go the sysinstall route and do a fresh install
> on ad1, exhibit same behaviour?

Yes, it does. I didn't use sysinstall but 'make installworld' but either doing
fdisk / disklabel by hand or by doing it using sysinstall, both methods stop
at the same 'cannot find root' prompt when booting off the slice. A reboot
into the old install later and my device entry is gone again.

> > script above shows the values that I obtained when /sbin/sysinstall
> > partitioned the drive. After partitioning the device nodes reappear, and
> > I was able to install{kernel,world} with DESTDIR pointing to the newly
> > mounted ad1s2, but the device nodes disappear after having booted the
> > newly installed slice. That boot ends with the kernel unable to find the
> > root file systemad1s2a (which is not strange given the above).
> > 
> > Am I looking at some sort of geometry bug? I've tried setting the BIOS
> > geometry settings to LBA (from Auto), that didn't make a difference.
> > Setting them to CHS produced an unbootable Windows so I reverted that.
> > In any case I thought that those values were of historical interest only...
> > 
> > Any clues?
> > 
> > --Stijn
> > 
> > PS: I thought that there was a sysctl that showed the GEOM topology in XML;
> >     however I was unable to find it in sysctl -a. Is it still around?
> I believe so, phk recently (few months back) mentioned it's staying in.

Too bad I couldn't find it...

Thanks for your reply,


Fairy tales do not tell children that dragons exist. Children already
know dragons exist. Fairy tales tell children the dragons can be
		-- G.K. Chesterton
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-current mailing list