Need help: buildworld for CURRENT while under STABLE is not working

YONETANI Tomokazu qhwt+freebsd-current at
Sun Aug 8 20:12:07 PDT 2004

[Cc on author and the list]
On Sun, Aug 08, 2004 at 09:39:46AM -0700, Michael C. Shultz wrote:
> > > > Do you get the same error if you run `make buildworld' without
> > > > -DDESTDIR=/ad1 ?
> I just cleaned everything up and tried, yes same exact failure.  Its trying to 
> pull stdint.h from /usr/include, I tested it by linking /usr/include/stdint.h 
> to /ad1/usr/include/stdint.h and it got past that one point.  Now, why the 
> heck is buildworld goint to userland for header files???????

Hmm, the problem is when building on STABLE, gensnmptree gets built in
bootstrap-tools stage (because it's not in STABLE but is needed to build
libbsnmp), where necessary header files are not yet populated under obj tree.
Probably you need to change contrib/gensnmptree/gensnmptree.c so as not to
use <stdint.h> at least when OSRELDATE < 500000.

More information about the freebsd-current mailing list