can see my reboot command idle 22 minutes :(

Bjoern A. Zeeb bzeeb-lists at
Thu Aug 5 11:10:10 PDT 2004


have a 1 year old 5.1-RELEASE system with SCSI and one 120GB IDE

The IDE disk got used for daily dumps since january.
Tonight I got this error:

 kernel: ad0: READ command timeout tag=0 serv=0 - resetting
 kernel: ata0: resetting devices ..

serial console had been unuseable at that point but sshing/telnetting
onto the system still worked.

A dump had still been running. kill -9 didn't help much nor did
reboot. The reboot simply hung other services terminated so no longer
been able to telnet onto the machine.

Hands on resetted the machine and it got up booting fine, serial
console worked. It started background fsck and I went away.

45 minutes later fsck simply hang, had not been able to kill -9

this time dmesg showed:
  ad0: WRITE command timeout tag=0 serv=0 - resetting
  ata0: resetting devices ..

Stopped some services by hand and did some funny things,
commented out the ide disk in /etc.fstab and typed reboot.

Well the machine ist still up an running:

bz at machine: {107} w
 7:58PM  up  1:06, 6 users, load averages: 0.05, 0.16, 0.08
USER             TTY      FROM              LOGIN@  IDLE WHAT
bz               p0       shell             7:30PM    26 ls -l /dump/
bz               p1       shell             7:32PM    25 sync
bz               p2       shell             7:33PM    22 reboot
bz               p3       shell             7:39PM    11 atacontrol reinit 0
bz               p5       shell             7:47PM     - w

see the reboot there :((

I can still log in by ssh, do funny things but everything accessing
the IDE disk simply hangs...

Unfortunately this is 5.1-RELEASE so no
	machine# sysctl debug.enter_debugger=ddb
	sysctl: unknown oid 'debug.enter_debugger'

hands on again ...

Bjoern A. Zeeb				bzeeb at Zabbadoz dot NeT

More information about the freebsd-current mailing list