xterm -C not working

Randy Bush randy at psg.com
Sun Apr 25 10:28:14 PDT 2004

>> xtem -C seems not to get console output on the xterm,
>> though, if i run in non-X, i do get console messages
>> ...
>> not sure this is related, but i noticed that the kernel
>> config
>>    options         UCONSOLE
>> is no longer legal (and the handbook on kernel configuration
>> forgot to remove it).
> This option opened a security hole in the broken TIOCCONS ioctl.
> I think xterm -C uses this ioctl.  The security hole was that
> everyone was permitted to take over the console.  Now only users
> who can open /dev/console for reading can take it over.  The
> brokenness is that TIOCCONS causes panics.  It apparently never
> worked, but it causes panics more reliably now because the bad
> things that it does are detected by locking assertions.

hmmm.  and, considering the devfs stuff, when/how can/should one
allow the X server user to have read perms?


More information about the freebsd-current mailing list