[Evil project] / ibm thinkpad t41

Bill Paul wpaul at FreeBSD.ORG
Fri Apr 23 10:28:02 PDT 2004

[Charset iso-8859-1 unsupported, filtering to ASCII...]
> On Fri, Apr 23, 2004 at 12:18:36AM +0200, Yann Berthier wrote:
> > 
> >    Hello list,
> > 
> >    My kernel jump to ddb whenever i try to load if_ndis.ko. I always
> >    thought it was the result of a pilot error as others seem to have a
> >    better mileage than me on this subject, but as i never had any
> >    success with any kernel i tried, i will gladly welcome any input.
> > 
> >    so, with a today kernel, the usual goat sacrifice and the following
> >    actions:
> > ndis0: <Intel(R) PRO/Wireless LAN 2100 3B Mini PCI Adapter> mem
> I'm not quite clear on the sub-modeling number IBM has, but the T41
> comes with different wireless cards. I tried hard to get mine to work
> with ndis, and failed. Suddenly in a flash of lightning it struck me
> that it might be an Atheros Chipset, and now I'm running happily with
> ath(4).
> No cookies for IBM for making it so hard to find out what chipset one
> actually is using.

And no cookies for you for ever bothering to tell me that you were
having problems with your atheros miniPCI card, or for failing to
describe what problems you had beyong "I tried to get it to work
and it failed."

If you don't describe the failure, nobody can offer a solution.

For the record, I _have_ gotten Atheros cards to work with the NDISulator,
so lacking any other details, I'm forced to conclude your problems were


-Bill Paul            (510) 749-2329 | Senior Engineer, Master of Unix-Fu
                 wpaul at windriver.com | Wind River Systems
              <adamw> you're just BEGGING to face the moose

More information about the freebsd-current mailing list