SHM options hose my system

jason jason at
Wed Apr 21 19:48:43 PDT 2004

I have done a quick googling and a search of tha mail archives with no 
I am running current that is maybe 2 weeks old.  I tried to install 
postgresql and found I needed more semaphores.  So I checked the docs 
for postgresql and found these items.  I cut and paste these defaults 
and uppon bootup of a new kernel I can't mount my hardrive. 

options         SHMMAXPGS=4096
options         SHMSEG=256
options         SEMMNI=256
options         SEMMNS=512
options         SEMMNU=256
options         SEMMAP=256

I haven't tried this yet, would I also need this with the other stuff?
#increases shared mem from 4mb to 32mb
options "SHMALL=8192"

At first the output from booting says I have a maxtor at 133mbs and al 
is good. If I don't have a cd in the drive my cdrom is forced to pio 
mode, but now even with a cd I get pio mode.  Then it adds some new 
stuff where dma fails and it retries to probe the cd.  It retries 
several times before it asks me for the root drive to mount.  I then 
booted my old kernel to write this.  Does anyone know the cause of 
this?  I will write up a pr if this is something new.

More information about the freebsd-current mailing list