USB Mass storage problems...

Adam K Kirchhoff adamk at
Sun Apr 18 07:59:50 PDT 2004

On Sun, 18 Apr 2004, Bernd Walter wrote:

> On Sat, Apr 17, 2004 at 06:29:23PM -0400, Adam K Kirchhoff wrote:
> >
> > I recently installed 5.2.1 on my machine.  I have previously run 5.2 on
> > this machine without any issues...  With 5.2.1 I noticed a problem with
> > umass.  I decided to upgrade to CURRENT in the hopes that this problem
> > would have been fixed (in addition to want to be on the cutting edge).
> > Unfortunately, the umass problem still seems to exist.
> >
> >
> >
> > Basically, I have two usb storage devices: a usb1 cf reader, and a usb2
> > CD/DVD burner.  The usb1 cf reader is plugged into the uhci controller,
> > and the usb2 CD/DVD device is plugged into the ehci controller.
> >
> > I have usb, uhci, ehci, ohci, and umass all compiled directly into the
> > kernel.  I have tried compiling umass as a module and loading it, but when
> > I do load the module, absolutely nothing happens.
> In some cases there are timing related problems with ehci disconnecting the
> busses aways from their companion controllers for reprobe.
> If you don't need any device at boot time you can set the #if 1 line in
> sys/dev/usb/usb.c to 0 for a workaround to delay probing.

Thanks for that tip.  Now my computer at least boots all the way up with
the umass driver compiled in, but it still doesn't attach to either umass
device.  Instead, I still get:

umass0: In-System Design USB Storage Adapter, rev 2.00/11.06, addr 2
umass0: Phase Error, residue = 95
umass0: Phase Error, residue = 95
umass0: Phase Error, residue = 95
umass0: Phase Error, residue = 95
umass0: Phase Error, residue = 95

Any other ideas?


More information about the freebsd-current mailing list