[SOLVED] Re: Can't *write* to a hard disk, problem related to GEOM(4)?

Julien Gabel jpeg at thilelli.net
Sat Apr 17 15:28:21 PDT 2004

>> The first thread for this subject begin from question@, you can read it
>> here:
>>  http://lists.freebsd.org/mailman/htdig/freebsd-questions/2004-April/\
>>  thread.html#43212
>> I can resume my problem like that:
>>  - My OS release is FreeBSD 5.2.1-RELEASE-p4;
>>  - The disk is a 120Go/8Mo from Maxtor (UDMA133);
>>  - What dmesg(8) says about it:
>>     # grep ad10 /var/run/dmesg.boot
>>     GEOM: create disk ad10 dp=0xc6ab2660
>>     ad10: 117246MB <Maxtor 6Y120P0> [238216/16/63] at ata5-master
>>      UDMA133
>>  - But when I tried to create a slice on it, I get:
>>     # fdisk -BI ad10
>>     ******* Working on device /dev/ad10 *******
>>     fdisk: can't write fdisk partition table: Operation not permitted

> Perhaps this is a silly question given the discussion of GEOM (of which
> I know nothing), but is it necessary to run this command in single-user
> mode?

No, there no need to run fdisk(8) in single-user mode. But this remark
made me think of another thing: the security level (init(8)). Because
there is no X Window on this machine and it acts as a server, I set up
the security level to '2'. The manual says in this case:
 "2   Highly secure mode - same as secure mode, plus disks may not be
      opened for writing (except by mount(2)) whether mounted or not.
      This level precludes tampering with file systems by unmounting
      them, but also inhibits running newfs(8) while the system is

So, after made the correct modifications, rebuild the RAID-1 array,
create all what is needed (slice, partition and fs ont it) and restore
the data on ar1s1x... all seems to work well and to be ok (so nothing
reltaed to GEOM(4)).

Thanks to all for your help,

More information about the freebsd-current mailing list