More odd behavior with the new PCI code (and, maybe, ata)

Ted Faber faber at ISI.EDU
Wed Apr 14 13:50:27 PDT 2004

On Wed, Apr 14, 2004 at 01:26:54PM -0700, Kevin Oberman wrote:
> I have noticed a very odd behavior since the new PCI code went into
> CVS. I have virtually no real data on the problem and no idea if it's
> really serious. It's only happened three time, always in single-user
> mode. 
> 1. boot -s
> 2. <CR> to start sh
> 3. fsck -p
> 4. adjkerntz -i
> 5. swapon -a
> 6. mount -a -t ufs
> 7. cd /usr/src
> These are the only things I am sure of as common. After this, an attempt
> to run something will simply hang. In mergemaster I had it happen when I
> tried to do an edit (e b) in a merge. Another time 'make installworld'
> hung in 'mktemp'. Interrupting the operation (^C) and restarting does
> not seem to help, but doing some other operation that accesses the disk
> seems to clear the problem. (E.g. ls /usr/src).

FYI I saw this same thing on a recent -CURRENT on a Dell 610.  I booted
single user, mounted -a (only local UFSs) and make installworld hung
without doing anything.  I rebooted then shutdown and installed world
and everything worked.  Sorry I can't be more precise.

Ted Faber           PGP:
Unexpected attachment on this mail? See 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-current mailing list