Dell Insp. 8200 doesn't find ata disks

Florian Nigsch flo at
Mon Apr 12 20:24:12 PDT 2004

Hi people!

I have a Dell Inspiron 8200, BIOS rev. A10, with an installed
FreeBSD, 5.2.1-RELEASE from the CD iso images. I recompiled
the kernel under this system, which worked fine.

Then I cvsup'ed the new sources (at the time of this writing I am
using the sources of about 12/04/2003 21:00 from
recompiled the world following the process indicated in the
proper documentation. Everything works without any errors.

When I try to boot with the new kernel of the now -CURRENT system,
it hangs when it is about to mount the root partition. I don't know
everything by heart, but it is the stuff:
setrootbyname failed,
unable to find root device, and then it gives the
mountroot> prompt.
When I type "?" there, there are NO bootable devices listed, which
is quite uncool.

My kernel finds the atapci0 driver/device, but then it doesn't find
the ata0 driver and so the ad0 device never get's initialized.

I already tried to turn off ACPI, which results in a kernel panic in an 
earlier step. hw.pci.allow_unsupported_pci_range="1" doesn't help

Extracts from the booting kernel:

ãtãþci0: <Ïntel Ï©H³ ÛàMù00 cøntrøller> þørt 0xbfã0-0xbfãfž0x³74-0x³77ž0x¹70-0x
¹77ž0x³f4-0x³f7ž0x¹f0-0x¹f7 ãt ðevice ³¹.¹ øn þci0
ãtã0: ãt 0x¹f0 irq ¹4 øn ãtãþci0
ãtã0: [MÞSÃFË]
ãtã¹: ãt 0x¹70 irq ¹5 øn ãtãþci0
ãtã¹: [MÞSÃFË]
GËØM: creãte ðisk ãð0 ðþ=0xc2e³2c60
ãð0: 286¹5MB <HÏTéHÏ_àK2³àÃ-³0> [58¹40/¹6/6³] ãt ãtã0-mãster ÛàMù00
ãcð0: ©à®W <HL-àT-ST©à-®W/àVà-®ØM G©©-4240N> ãt ãtã0-slãve ÞÏØ4
Møunting røøt frøm ufs:/ðev/ãð0s³ã

These last lines never occur with the -CURRENT kernel.

I looked everywhere for a solution to this problem, tried to cvsup the
newest sources two times, recompiled everything, included the ROOTDEVICE
option in the kernelconfig file, tried to hardcode the rootdisk in
/boot/loader.conf . But of course, this all can't work, if there just
simply are no /dev/ad0 devices.

How can I make my system recognize the ad0 device? The bootloader in 
the beginning recognizes them, I can do an "ls" and see all the
contents of the harddrive. The -CURRENT kernel just forgets about the
ad0 devices in some way.

Any help will be greatly appreciated!

Thank you very much,


Florian Nigsch <flo at> | <nigsch at>
PGP key:
Mail automatically filtered for spam by spambayes

More information about the freebsd-current mailing list