VIA 8253 UDMA ICRC errors

Yura Socolov fbsd-current.z.yurasocolov at
Thu Apr 8 21:26:13 PDT 2004

Following is a message i sent to -hardware last night. I have since tried 
this on -current as of today and,  since i  get the same kind of behavior, i 
thought i'd ask here as well.

The errors i'm getting are like this:

ad0: WARNING - WRITE_DMA UDMA ICRC error (retrying request) LBA=297945007
ad0: WARNING - WRITE_DMA UDMA ICRC error (retrying request) LBA=297945007
ad0: FAILURE - WRITE_DMA status=51<READY,DSC,ERROR> error=84<ICRC,ABORTED> LBA=297945007

Errors seem to snowball after a few minutes after boot, unless bg fsck kicks 
in, in which case they are there right away.

This is on a Shuttle AK32VN motherboard (KT266, 8235) with a samsung 160G disk,
but as mentioned below other VIA-based motherboads manifest the dame problems.

I guess question at this point is whether this is something that's temporarily
broken, bad hardware (but it works with other motherboards), something that is
no longer supported or something else.

Or i'm doing something wrong.

Any advice would be appreciated, thank you.

-- Yura Socolov <nospam>                   FP: A7192ABD96E15F5 19AB21E60C34109
-- Opinions and views in this message are my own and my own only.
-- "Two wrongs don't make a right... and three rights make a left." -- TRACON

>Does anyone else have a problem lately with VIA-based motherboards and relatively
>big IDE harddrives?
>In particular, any combination of the following gives me a load of UDMA ICRC 
>errors of various kinds, sometimes random panics (during boot or 20 minutes later), 
>corrupted filesystems, etc.
>I have tried using two different 160G hard drives from two different vendors 
>(maxtor and samsung), on three different, VIA-based motherboards of various
>age and from 3 different manufacturers (asus, shuttle, fic), using either VIA 
>686 or VIA 8235 chip, three different cables (so it's not a cable problem). 
>DDR and PC133 memory as needed. FreeBSD versions from 5.2, to 5.2.1, -stable as 
>of yesterday and about three weeks ago, and now compiling -current to check it out.
>If the drive is put in the BIOSPIO mode, everything works just dandy, including
>under heavy load on any of the boards. Under DMA100 i see ICRC errors as soon as
>there is more or less noticeable activity on the drive. For instance installing 
>from CD causes an immediate error, installing from ftp at about 300 Kbytes/sec 
>manages to survive, sometimes to the end of the minimalistic install process.
>If any of these drives are put in an amd64 box with FIC K8-800T (VIA 8237 chip),
>everything works flawlessly even under heavy load...
>I did see one similar bug report from last year in the non-urgent category, with no
>followups. Not sure if it's related, though, and I would call this more of a 
>critical problem,  since installation of FreeBSD on these kinds of systems is 
>currently just not possible.

More information about the freebsd-current mailing list