ASUS P4C800-E Deluxe and ICH5R support

Jeff Doolittle jdoolittle at
Thu Apr 8 16:54:42 PDT 2004

I've seen eMails regarding ICH5R support on other motherboards being 
added, is there plans to add support for the ASUS P4C800-E Deluxe?

I tried both FreeBSD v5.2.1 & am now updating to current on a daily 
basis hoping the following error will be address:

    ad12: TIMEOUT - WRITE_DMA retrying (2 retries left) LBA = xxxx
    ad10: TIMEOUT - WRITE_DMA retrying (2 retries left) LBA = xxxx
    the machine is hung, requiring a hard reset.

The following are from dmesg:

FreeBSD 5.2-CURRENT #0: Thu Apr  8 13:27:36 EDT 2004
    root at
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Pentium(R) 4 CPU 2.40GHz (2398.85-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0xf25  Stepping = 5
  Hyperthreading: 2 logical CPUs
real memory  = 536018944 (511 MB)
avail memory = 514789376 (490 MB)
atapci0: <Promise PDC20378 SATA150 controller> port 
0xd880-0xd8ff,0xdfa0-0xdfaf,0xdf00-0xdf3f mem 
0xfeac0000-0xfeadffff,0xfeafe000-0xfeafefff irq 23 at device 4.0 on pci3
ata2: at 0xfeafe000 on atapci0
ata3: at 0xfeafe000 on atapci0
ata4: at 0xfeafe000 on atapci0
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci1: <Intel ICH5 UDMA100 controller> port 
0xfc00-0xfc0f,0-0x3,0-0x7,0-0x3,0-0x7 at device 31.1 on pci0
ata0: at 0x1f0 irq 14 on atapci1
ata1: at 0x170 irq 15 on atapci1
atapci2: <Intel ICH5 SATA150 controller> port 
irq 18 at device 31.2 on pci0
ata5: at 0xefe0 on atapci2
ata6: at 0xefa0 on atapci2
ad0: 19092MB <ST320413A> [38792/16/63] at ata0-master UDMA100
acd0: CDRW <48X12X50 CD-RW 1.04 20021101> at ata1-master PIO4
ad4: 190782MB <WDC WD2000JD-00FYB0> [387621/16/63] at ata2-master UDMA100
ad6: 190782MB <WDC WD2000JD-00FYB0> [387621/16/63] at ata3-master UDMA100
em0: Link is up 100 Mbps Full Duplex
ad10: 190782MB <WDC WD2000JD-00FYB0> [387621/16/63] at ata5-master UDMA100
ad12: 190782MB <WDC WD2000JD-00FYB0> [387621/16/63] at ata6-master UDMA100
ar0: 381564MB <ATA RAID0 array> [48642/255/63] status: READY subdisks:
 disk0 READY on ad4 at ata2-master
 disk1 READY on ad6 at ata3-master
ar1: 381564MB <ATA RAID0 array> [48642/255/63] status: READY subdisks:
 disk0 READY on ad10 at ata5-master
 disk1 READY on ad12 at ata6-master

NOTE #1:  ar0 is a Promise created RAID array.
NOTE #2:  at1 is a atacontrol created RAID array, because the BIOS 
created is not recognized.

Basically the machine crashed when I run rsync from the Promise raid 
drives to the Intel raid drives.  In the past I could copy between 1 - 
2gig and it would hang with the above error messages, except yesterday's 
build dumped me in debug mode, today's build is the first I have seen it 
acknowlegde the Intel ICH5 SATA150 controller and it errors out almost 
immediately after starting rsync.

Is there more information I can/should provide to help resolve this 
problem?  I apologize, this is the first time I've ever had a "problem" 
with FreeBSD since I started using it at v2.2.7....


       - Jeff


More information about the freebsd-current mailing list