cvsup failing with "ASSERT failed"

Jon Noack noackjr at
Sun Apr 4 03:06:57 PDT 2004

On 4/3/2004 10:55 PM, Steve Kargl wrote:
> On Tue, Aug 26, 2003 at 10:58:36PM -0500, none wrote:
>>A couple of times, now, on both FBSD-5.1-CURRENT and FBSD-4.8-STABLE whilst 
>>running with 2MB of RAM, cvsup has "croaked" with the following error:
>>*** runtime error:
>>***    ASSERT failed
>>***    file "/usr/ports/lang/ezm3/work/ezm3-1.0/libs/m3core/src/runtime/
>>common/RTHeapMap.m3", line 35
>>   use option @M3stackdump to get a stack trace
>>Abort trap (core dumped)
> 2MB? Are you serious?

This must be a typo -- even PicoBSD requires 4MB of RAM to do anything 
useful.  I ran a 486/DX4 100MHz machine with 20MB of RAM (the max for 
the motherboard) as a WINS server for a while (to help link college dorm 
subnets so people would see more computers in Network Neighborhood). 
The only way I kept the machine up-to-date was to build world, kernel, 
and packages on another machine and then install over NFS.  This worked 
pretty well, although an installworld over NFS on a fast network still 
took a few hours.  I started using this method after I let a buildworld 
go for over 2 _days_ without finishing, and this with 4.x (5.x would be 
even longer!).  The disk performance was so bad that swapping over NFS 
actually *sped* things up.  In any case, the machine was rock solid, 
though, racking up 100+ day uptimes between security patches.  It was 
actually this machine that got me started with FreeBSD, because 20MB of 
RAM was too little for RedHat (I think it needed 32MB).  I've been using 
FreeBSD ever since...


More information about the freebsd-current mailing list