5.2.1 hangs on boot where 5.1 does not (ATA issue)

R. David Murray rdmurray at bitdance.com
Sat Apr 3 12:44:38 PST 2004

On Sat, 3 Apr 2004, R. David Murray wrote:
> master and slave).  Changing that to master changed the symptoms,
> but I'm still in a situation where I can boot with 5.1 but not
> (at least not completely) wit 5.2.

Update: I got a UDMA cable.  That took me back to my previous
symptoms (the hang) until I relized I'd put the master at the
controller spot on the cable.  Swapped that, and now I was
back at my second set of symptoms (error on ad2).  Having
seen some postings about incopatabilities between CDRom drives
and harddrives on the same controller, I decided to move the
hard drive to controller 1 to see what would happen.  I can
now boot 5.2 cleanly.

So, things are solved for me.  But I worry that a hardware combo
that worked under 5.1 no longer works under 5.2.  And I'm going
to be trying to put a different DVD/HD combo on that second
controller later this week; I hope I get lucky and they work

Oh, and thanks for your help, Tim; I'd never have figured this out
if you hadn't suggested checking the jumpers, because I was *sure*
my hardware was working fine <wry grin>.


More information about the freebsd-current mailing list