Upgrade experience 5.1p10->5.2 Beta

Justin Smith jsmith at drexel.edu
Sat Nov 29 07:11:58 PST 2003


First I tried making world and kernel from the cvsup'ed standard 
supfile. This went OK.

Then I did installkernel and installworld (in that order) and the second 
step crashed with messages that shared libraries were missing. (It's as 
if it installed some files before installing the shared libraries they 
needed).

I was able to reboot and manually copy over many of the shared libraries 
from /usr/obj/usr/src/lib to /usr/lib and this got rid of the complaints.

Then, I tried running make installworld again, just to be sure 
everything got installed. This went for about 20 minutes and crashed with

gencat command not found.

Manually copying this over to /usr/bin (and manually copying all of the 
shared libraries again, because they would be missing after the crashed 
make installworld) didn't solve this problem. Odd, since the old system 
had a gencat command too.


Finally, I just burned a CD with the 5.2 beta mini-install (using 
Slackware Linux...). I ran upgrade and everything seems OK.

One problem: my Nvidia GEForce 2 MX card no longer works (of course, I 
reinstalled the nvidia kernel driver). It has the same problem it had 
more than a month ago when I was briefly tracking current:

attempting to use it reboots the machine. I type 'xinit' and see the 
power-on self test screen for the motherboard appears. No error 
messages, etc.

I vaguely recall that I solved this the last time by setting parameters 
in the bootloader that showed the AGP interface down. After doing that, 
I could run X windows but any OpenGL (OpenUniverse, Celestia) rebooted 
the machine.

Questions:

1. Will the AGP performance be brought up to the level of 5.1p10 before 
5.2 is released (so I don't have to slow the AGP interface and can do 
OpenGL)?

2. Why does the system fail in such an non-robust and uninformative 
fashion? Why no error messages?



More information about the freebsd-current mailing list