xl0: watchdog timeout

Kris Kennaway kris at obsecurity.org
Fri Nov 21 16:19:33 PST 2003

On Fri, Nov 21, 2003 at 11:40:37PM +0100, Jimmy Selgen wrote:

> The box in question is my workstation, so I guess i'm not passing that
> much traffic through ipfilter. Also, when I said that the NIC still
> worked, I might have mislead you a bit. I had about 5-10 timeouts while
> scp'ing the dmesg output to my other workstation.
> Data seems to move from userland to the kernel, then get stuck in
> buffers there for 10-15 seconds, "generating" timeouts, before they're
> shipped off. I assume this is expected behaviour when a NIC isnt
> behaving correctly.

OK, it's still possible something is triggering a locking bug.  Or
your problem could be elsewhere.

> > It would be helpful if you can do a binary search to narrow down when
> > the problem started.
> What would you have me search ? I'm a faily seasoned C programmer (12
> years experience, some of them doing RTOS kernel work), but dont know
> much about FreeBSD kernel development, or the process of checking out
> different kernel revisions.

You have a couple of choices..if you update your sources by cvsup,
there's a date keyword you can use in your cvsupfile to select sources
from that date.  If you're using cvsup to fetch a local repository and
then cvs to check out from there, cvs also has the -D keyword you can
use to update to a date string.  Using cvs is better, because you can
easily control it on the level of individual file revisions once you
get down to testing a few specific changes.  Setting up cvs and cvsup
are both documented on the freebsd website.

Basically, if you can iterate through different dates, halving the
date between the last kernel you know worked and the first kernel you
know did not, to push the boundaries down, it will narrow down the
range of commits that caused the problem.  

> I've tried a build without IPFILTER, and the problem still exists.
> I've also tried booting with ACPI disabled, and the problem is still
> there.

OK, that probably rules them out.

> I have attached a copy of my kernel config file, in case i'm doing
> something wrong.

Looked OK to me.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-current/attachments/20031121/8bc9c609/attachment.bin

More information about the freebsd-current mailing list