hard lock-up writing to tape

Mike Durian durian at boogie.com
Thu Nov 20 08:59:50 PST 2003

On Wednesday 19 November 2003 02:15 pm, Bruce Evans wrote:
> Anyway, the stuff to the left of the slash in the above is the list
> of active consoles and the stuff to the right of the slash is the
> list of possible consoles.  You have to move stuff from one list to
> the other.  I vaguely remember that this is done using '-' to delete
> things from the left hand list and something more direct to add them.

You remember correctly.  Thanks for the info.  However, I think I'm
going to have to throw in the towel on this.  When I swap the
console output using the kern.console sysctl, I can get user application
console output to appear on the remote machine - just nothing from
the kernel.

For example, if I 'echo hello > /dev/console', hello will appear on
the remote machine.  But I never see any of the bold face messages,
such as the very frequent:

checking stopevent 2 with the following non-sleepable locks held:
exclusive sleep mutex sigacts r = 0 (0xc6b6faa8) locked @ /disk2/src/sys/kern/

When I tried to generate a break using ~# from tip to drop into the
debugger, nothing happens, so I don't think the serial console is
fully connected in the kernel, even though the bold-face output
disappeared from the syscons console.

I do have an extra bit of information on my original tape lock-up
problem.  At one point, when I thought I had the remote console
working and was reproducing the problem, the tape backup worked
fine until I pinged the machine.  I think the machine responded
to the ping and then that was it.  It locked up solid.


More information about the freebsd-current mailing list