vinum error: statfs related?

Eric Anholt eta at
Mon Nov 17 13:01:10 PST 2003

On Sun, 2003-11-16 at 20:14, Daryl Chance wrote:
> I am currently not able to load my vinum array
> (haven't tried to revert back to pre-statfs source)
> after I built a new kernel and world.  I upgraded the
> recommended way (installkernel, reboot, single user
> mode, installworld, etc) and when my box boots I get
> "vinum loaded, no drives found".  When I go to
> kldunload vinum, it unloads but I get the error:
> vinum: exiting with malloc table inconsistency at
> 0xc2f49400 from vinumio.c:755
> vinum: unloaded
> I checked the pr's, but haven't seen anything yet
> listed in there.  Should I do a sendpr?  I'm basically
> using the generic conf, with the exception that I've
> removed 486 and 586 and changed the ident.
> I don't have a lint config, so i don't know how to
> compile vinum into the kernel to test if that fixes
> it.  If theres anymore info needed, I'd be glad to
> give access to the box or email a dmesg.

I'm getting the same (no drives/subdisks/plexes/volumes found) trying to
upgrade from a Nov 11 kernel/userland to Nov 16th kernel.  I tried
seeing if using a Nov 16th vinum binary would load them, but after doing
a stop/start, the system paniced, and it seems my swap is too small to
dump on.  Kernel was built using configure MYKERNEL; cd
../compile/MYKERNEL; make depend all install instead of buildkernel. 
DDB enabled but no invariants/witness, not sure what else from my config
might be applicable.

Eric Anholt                                eta at          anholt at

More information about the freebsd-current mailing list