hit g_provider %p disappeared while tasting

Bjoern A. Zeeb bzeeb-lists at lists.zabbadoz.net
Mon Nov 17 12:43:38 PST 2003


Hi,

I am pxebooting an md_image as root fs. While this worked for cvsup
sources from around 20031115-1501 UTC it fails woth same kernel config
with sources from today 20031117-1435 UTC.

--- 20031115-1501 ---
...
IPsec: Initialized Security Association Processing.
Mounting root from ufs:/dev/md0c
Loading configuration files.
Entropy harvesting:.
...
--- end ---


--- 20031117-1435 ---
IPsec: Initialized Security Association Processing.
g_provider 0xc2f6ee80 disappeared while tasting
Mounting root from ufs:/dev/md0c
setrootbyname failed
ffs_mountroot: can't find rootvp
Root mount failed: 6
Mounting root from ufs:/dev/md0
setrootbyname failed
ffs_mountroot: can't find rootvp
Root mount failed: 6

Manual root filesystem specification:
  <fstype>:<device>  Mount <device> using filesystem <fstype>
                       eg. ufs:da0s1a
  ?                  List valid disk boot devices
  <empty line>       Abort manual input

mountroot> ?
panic: Root mount failed, startup aborted.

--- end ---

nb: please ignore the '?' panic. This is another problem.


The problem seems to be triggered by following commit:
http://www.freebsd.org/cgi/cvsweb.cgi/src/sys/geom/geom_subr.c.diff?r1=1.61&r2=1.62&sortby=date&f=h


If I can help to sort this out please let me know. I building too many
HEADs these days anyway ;-)

-- 
Bjoern A. Zeeb				bzeeb at Zabbadoz dot NeT
56 69 73 69 74				http://www.zabbadoz.net/


More information about the freebsd-current mailing list