mouse not working as of latest kernel

David Hill hill at phobia.ms
Sun Nov 16 19:21:31 PST 2003


Hello -

My mouse stopped working with the latest kernel compile.  The mouse was working with my November 11 2003 kernel though.

it is an IBM optical mouse using USB.

my dmesg is attached.

- David


-------------- next part --------------
Copyright (c) 1992-2003 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD 5.1-CURRENT #1: Sun Nov 16 22:13:02 EST 2003
    david at wind.mindcry.org:/usr/src/sys/i386/compile/WIND
Preloaded elf kernel "/boot/kernel/kernel" at 0xc08e1000.
Preloaded acpi_dsdt "/boot/dell.dsl" at 0xc08e126c.
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Pentium(R) 4 Mobile CPU 1.70GHz (1695.01-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0xf24  Stepping = 4
  Features=0x3febf9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM>
real memory  = 267911168 (255 MB)
avail memory = 250535936 (238 MB)
Pentium Pro MTRR support enabled
ACPI: DSDT was overridden.
    ACPI-0375: *** Info: Table [DSDT] replaced by host OS
acpi0: <DELL     RSDT  > on motherboard
pcibios: BIOS version 2.10
Using $PIR table, 8 entries at 0xc00fdf40
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on acpi0
acpi_cpu0: <CPU> port 0x530-0x537 on acpi0
acpi_lid0: <Control Method Lid Switch> on acpi0
acpi_button0: <Power Button> on acpi0
acpi_button1: <Sleep Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib0: slot 29 INTA is routed to irq 10
pcib0: slot 29 INTB is routed to irq 11
pcib0: slot 31 INTB is routed to irq 10
pcib0: slot 31 INTB is routed to irq 10
pcib0: slot 31 INTB is routed to irq 10
agp0: <Intel 82845 host to AGP bridge> mem 0xec000000-0xefffffff at device 0.0 on pci0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pcib1: slot 0 INTA is routed to irq 10
pci1: <display, VGA> at device 0.0 (no driver attached)
uhci0: <Intel 82801CA/CAM (ICH3) USB controller USB-A> port 0x1800-0x181f irq 10 at device 29.0 on pci0
usb0: <Intel 82801CA/CAM (ICH3) USB controller USB-A> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
ums0: Primax Electronics product 0x4d03, rev 1.00/4.41, addr 2, iclass 3/1
ums0: 3 buttons and Z dir.
uhci1: <Intel 82801CA/CAM (ICH3) USB controller USB-B> port 0x1820-0x183f irq 11 at device 29.1 on pci0
usb1: <Intel 82801CA/CAM (ICH3) USB controller USB-B> on uhci1
usb1: USB revision 1.0
uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
pcib2: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci2: <ACPI PCI bus> on pcib2
pcib2: slot 1 INTA is routed to irq 10
pcib2: slot 4 INTA is routed to irq 10
xl0: <3Com 3c905C-TX Fast Etherlink XL> port 0x3000-0x307f mem 0xe8000000-0xe800007f irq 10 at device 1.0 on pci2
xl0: Ethernet address: 00:08:74:3f:d1:e3
miibus0: <MII bus> on xl0
ukphy0: <Generic IEEE 802.3u media interface> on miibus0
ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
cbb0: <O2Micro OZ6912/6972 PCI-CardBus Bridge> irq 10 at device 4.0 on pci2
cardbus0: <CardBus bus> on cbb0
pccard0: <16-bit PCCard bus> on cbb0
cbb0: [MPSAFE]
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH3 UDMA100 controller> port 0x1840-0x184f,0-0x3,0-0x7,0-0x3,0-0x7 at device 31.1 on pci0
ata0: at 0x1f0 irq 14 on atapci0
ata0: [MPSAFE]
ata1: at 0x170 irq 15 on atapci0
ata1: [MPSAFE]
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
pcm0: <Intel ICH3 (82801CA)> port 0x1880-0x18bf,0x1c00-0x1cff irq 10 at device 31.5 on pci0
pcm0: <SigmaTel STAC9700/83/84 AC97 Codec>
pci0: <simple comms> at device 31.6 (no driver attached)
atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model Generic PS/2 mouse, device ID 0
acpi_acad0: <AC Adapter> on acpi0
acpi_ec0: <Embedded Controller: GPE 0x1c> port 0x66,0x62 on acpi0
acpi_ec0: info: new max delay is 27 us
acpi_ec0: info: new max delay is 50 us
acpi_ec0: info: new max delay is 130 us
acpi_ec0: info: new max delay is 200 us
acpi_cmbat0: <Control Method Battery> on acpi0
ppc0 port 0x778-0x77f,0x378-0x37f irq 7 drq 3 on acpi0
ppc0: Generic chipset (ECP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/8 bytes threshold
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
fdc0: <Enhanced floppy controller (i82077, NE72065 or clone)> port 0x3f7,0x3f0-0x3f5 irq 6 drq 2 on acpi0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
npx0: [FAST]
npx0: <math processor> on motherboard
npx0: INT 16 interface
orm0: <Option ROMs> at iomem 0xdc000-0xdffff,0xce000-0xce7ff,0xc0000-0xcdfff on isa0
pmtimer0 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 8250 or not responding
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 1695011380 Hz quality 800
Timecounters tick every 10.000 msec
IPv6 packet filtering initialized, logging limited to 50 packets/entry
ipfw2 initialized, divert disabled, rule-based forwarding enabled, default to deny, logging limited to 50 packets/entry by default
IPsec: Initialized Security Association Processing.
acpi_cpu0: set speed to 100.0%
acpi_cpu: throttling enabled, 8 steps (100% to 12.5%), currently 100.0%
acpi_acad0: acline initialization start
acpi_acad0: On Line
acpi_acad0: acline initialization done, tried 1 times
acpi_cmbat0: battery initialization start
acpi_ec0: info: new max delay is 400 us
acpi_ec0: info: new max delay is 500 us
acpi_ec0: info: new max delay is 600 us
acpi_ec0: info: new max delay is 21000 us
acpi_cmbat0: battery initialization done, tried 1 times
GEOM: create disk ad0 dp=0xc2e07760
ad0: 28615MB <HITACHI_DK23DA-30> [58140/16/63] at ata0-master UDMA100
acd0: CDRW <TEAC CD-RW CD-W224E> at ata1-master PIO4
Mounting root from ufs:/dev/ad0s1a
nvidia0: <GeForce2 Go> mem 0xf0000000-0xf7ffffff,0xe0000000-0xe0ffffff irq 10 at device 0.0 on pci1
Warning: pid 665 used static ldt allocation.
See the i386_set_ldt man page for more info


More information about the freebsd-current mailing list