DWL-G520 (Atheros 5212) x FreeBSD

Neilson Henriques neilson at predialnet.com.br
Sun Nov 16 16:44:13 PST 2003

Hi ! 

    After read the man page of ath(4) driver I decided to 
    buy a DWL-G520 but it is insisting to not joy with me. :-(
    I tried to replace the board, replace the machine, reinstall
    the FreeBSD and cvsup the today code, get and install a 
    snapshot, every try without success. 
    I always get the same error: 

    ath0: <Atheros 5212> mem 0xf3000000-0xf300ffff irq 18 at device 14.0 on pci2
    ath0: unable to attach hardware; HAL status 13
    device_probe_and_attach: ath0 attach returned 6

    pciconf -lv shows: 

    none1 at pci2:14:0:        class=0x020000 card=0x3a131186 chip=0x0013168c rev=0x01 hdr=0x00
    vendor   = 'Atheros Communications Inc.'
    class    = network
    subclass = ethernet

    ath(4) says "unable to attach hardware" and the sys/contrib/dev/ath/ah.h
    indicates an incompatibily in this hardware revision. 

    Does anybody have a "secret" patch do make it working ? :-) 
    Sam ?? Helppppp ... hheeellllppp ... :-) 

    Thanks for the attention ... 



More information about the freebsd-current mailing list