upgraded to CURRENT = system is dead

Michael Collette metrol at metrol.net
Sun Nov 16 13:03:09 PST 2003

I just ran into this very same thing today on a brand new installation.  Upon 
reboot I can't even get to a shell.  Was rather hoping someone had some more 
information about this.

Running the installation on an IBM xSeries 305 with a P4.  Going to try the 
installation fresh with a cvsup back to Nov 1st to see how it goes.  Thank 
the Unix gods this wasn't a production machine.

Antoine Jacoutot wrote:
> Selon Dylan Wylie <d.wylie at hccnet.nl>:
>> The idea is that you need to build a new kernel with the new sources
>> before you install
>> world.
>> You built your kernel before building the sources, so your kernel is
>> based on old source.
>> Quoting from another message:
>> > make buildworld
>> > make buildkernel
>> > make installkernel
>> > reboot
>> > make installworld
> --> yes... but I get this during the installworld:
> /libexec/ld-elf.so.1: Shared object "libedit.so.4" not found
> Stop in /usr/src
> :(
> I just tried it again from scratch but got the same error... !
> If anyone has an idea...

"In theory, there is no difference between theory and practice.
In practice, there is."
- Yogi Berra

More information about the freebsd-current mailing list