buildworld fails

Peter Ulrich Kruppa root at pukruppa.net
Sun Nov 16 11:10:04 PST 2003


Hi!

I have a problem with today's sources.

At my first try make buildworld and make kernel worked all-right
and the new kernel could be booted, so I didn't check closely and
made installworld. This failed *somewhere* , and now I am left
with a defect system: no internet connection, no XFree86 and
perhaps some more things I haven't found yet.

Next I deleted /usr/obj/usr and /usr/src and cvsupped fresh
sources (via a a basic 4.8 -RELEASE I have got on the same
machine), but now buildworld fails very soon with

	---------------------------------------------------
===> tools/build
/usr/obj/usr/src/i386/usr/src/tools/build created for /usr/src/tools/build
cd /usr/src/tools/build; make buildincludes; make installincludes
rm -f .depend
mkdep -f .depend -a    -I/usr/obj/usr/src/i386/legacy/usr/include  /usr/src/tool
s/build/dummy.c
cc -O -pipe  -I/usr/obj/usr/src/i386/legacy/usr/include -c /usr/src/tools/build/
dummy.c
building static egacy library
ranlib libegacy.a
sh /usr/src/tools/install.sh -C -o root -g wheel -m 444   libegacy.a /usr/obj/us
r/src/i386/legacy/usr/lib
*** Signal 11

Stop in /usr/src/tools/build.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.

	----------------------------------------------------

Does anybody else see this (so I can wait until it is repaired)
or is something fundamentally messed up on my system?

Thanks for hints and trouble-shooting advices.

Uli.


More information about the freebsd-current mailing list