ddb and usb keyboard

Sven Esbjerg esbjerg at xbsd.net
Mon Nov 10 12:49:08 PST 2003


I primarily use a usb keyboard on my PC. After an upgrade this weekend the kernel
paniced and went into ddb. Unfortunately the usb keyboard does not work in
ddb mode. Thus I can only pull the plug :(

MB is a Supermicro P3TDDE with two PIII 800MHz CPU's. Chipset is:
# dmesg |grep VIA
acpi0: <VIA694 AWRDACPI> on motherboard
agp0: <VIA Generic host to PCI bridge> mem 0xf0000000-0xf3ffffff at device 0.0 on pci0
uhci0: <VIA 83C572 USB controller> port 0xb800-0xb81f irq 11 at device 17.2 on pci0
usb0: <VIA 83C572 USB controller> on uhci0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhci1: <VIA 83C572 USB controller> port 0xbc00-0xbc1f irq 11 at device 17.3 on pci0
usb1: <VIA 83C572 USB controller> on uhci1
uhub2: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhci2: <VIA 83C572 USB controller> port 0xc000-0xc01f irq 11 at device 17.4 on pci0
usb2: <VIA 83C572 USB controller> on uhci2
uhub3: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1

keyboard is a Sun Type 6 keyboard.

dmesg is attached.

Sven Esbjerg
-------------- next part --------------
Copyright (c) 1992-2003 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD 5.1-CURRENT #0: Tue Oct 28 21:33:03 CET 2003
    root at enzo.home.xbsd.net:/usr/src/sys/i386/compile/ENZO.DBG
Preloaded elf kernel "/boot/kernel.old/kernel" at 0xc08e1000.
Preloaded elf module "/boot/kernel.old/acpi.ko" at 0xc08e11f8.
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel Pentium III (801.82-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x683  Stepping = 3
  Features=0x383fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE>
real memory  = 1073676288 (1023 MB)
avail memory = 1033502720 (985 MB)
Programming 24 pins in IOAPIC #0
IOAPIC #0 intpin 2 -> irq 0
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
 cpu0 (BSP): apic id:  0, version: 0x00040011, at 0xfee00000
 cpu1 (AP):  apic id:  1, version: 0x00040011, at 0xfee00000
 io0 (APIC): apic id:  2, version: 0x00178011, at 0xfec00000
Pentium Pro MTRR support enabled
npx0: <math processor> on motherboard
npx0: INT 16 interface
acpi0: <VIA694 AWRDACPI> on motherboard
pcibios: BIOS version 2.10
Using $PIR table, 8 entries at 0xc00fdef0
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x4008-0x400b on acpi0
acpi_cpu0: <CPU> port 0x530-0x537 on acpi0
acpi_cpu1: <CPU> port 0x530-0x537 on acpi0
acpi_tz0: <Thermal Zone> port 0x530-0x537 on acpi0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0x5000-0x500f,0x4080-0x40ff,0x4000-0x407f,0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
IOAPIC #0 intpin 11 -> irq 2
IOAPIC #0 intpin 10 -> irq 5
IOAPIC #0 intpin 5 -> irq 10
IOAPIC #0 intpin 12 -> irq 11
agp0: <VIA Generic host to PCI bridge> mem 0xf0000000-0xf3ffffff at device 0.0 on pci0
pcib1: <PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pci1: <display, VGA> at device 0.0 (no driver attached)
adv0: <AdvanSys ASC3030/50 SCSI controller> port 0x9000-0x90ff mem 0xfa221000-0xfa2210ff irq 2 at device 7.0 on pci0
adv0: AdvanSys SCSI Host Adapter, SCSI ID 7, queue depth 16
pcm0: <Creative EMU10K1> port 0x9400-0x941f irq 5 at device 8.0 on pci0
pcm0: <TriTech TR28602 AC97 Codec>
pci0: <multimedia> at device 10.0 (no driver attached)
atapci0: <Promise PDC20267 UDMA100 controller> port 0xac00-0xac3f,0xa800-0xa803,0xa400-0xa407,0xa000-0xa003,0x9c00-0x9c07 mem 0xfa200000-0xfa21ffff irq 5 at device 12.0 on pci0
atapci0: [MPSAFE]
ata2: at 0x9c00 on atapci0
ata2: [MPSAFE]
ata3: at 0xa400 on atapci0
ata3: [MPSAFE]
fxp0: <Intel 82559 Pro/100 Ethernet> port 0xb000-0xb03f mem 0xfa100000-0xfa1fffff,0xfa220000-0xfa220fff irq 11 at device 13.0 on pci0
fxp0: Ethernet address 00:30:48:41:b9:ba
miibus0: <MII bus> on fxp0
inphy0: <i82555 10/100 media interface> on miibus0
inphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
isab0: <PCI-ISA bridge> at device 17.0 on pci0
isa0: <ISA bus> on isab0
atapci1: <VIA 8233 UDMA100 controller> port 0xb400-0xb40f at device 17.1 on pci0
ata0: at 0x1f0 irq 14 on atapci1
ata0: [MPSAFE]
ata1: at 0x170 irq 15 on atapci1
ata1: [MPSAFE]
uhci0: <VIA 83C572 USB controller> port 0xb800-0xb81f irq 11 at device 17.2 on pci0
uhci0: LegSup = 0x2010
usb0: <VIA 83C572 USB controller> on uhci0
usb0: USB revision 1.0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhub0: port error, restarting port 1
uhub0: port error, giving up port 1
uhub1: Texas Instruments TUSB2046 hub, class 9/0, rev 1.10/1.25, addr 2
uhub1: 4 ports with 4 removable, self powered
ugen0: OmniVision OV511+ Camera, rev 1.00/1.00, addr 3
uhub0: port error, restarting port 2
uhub0: port error, giving up port 2
ums0: Logitech USB Mouse, rev 1.10/6.10, addr 4, iclass 3/1
ums0: 4 buttons and Z dir.
uhci1: <VIA 83C572 USB controller> port 0xbc00-0xbc1f irq 11 at device 17.3 on pci0
uhci1: LegSup = 0x2010
usb1: <VIA 83C572 USB controller> on uhci1
usb1: USB revision 1.0
uhub2: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
uhub2: port error, restarting port 1
uhub2: port error, giving up port 1
uhub2: port error, restarting port 2
uhub2: port error, giving up port 2
uhci2: <VIA 83C572 USB controller> port 0xc000-0xc01f irq 11 at device 17.4 on pci0
uhci2: LegSup = 0x2010
usb2: <VIA 83C572 USB controller> on uhci2
usb2: USB revision 1.0
uhub3: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub3: 2 ports with 2 removable, self powered
uhub3: port error, restarting port 1
uhub3: port error, giving up port 1
uhub3: port error, restarting port 2
uhub3: port error, giving up port 2
fdc0: <Enhanced floppy controller (i82077, NE72065 or clone)> port 0x3f7,0x3f0-0x3f5 irq 6 drq 2 on acpi0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
sio0 port 0x3f8-0x3ff irq 4 on acpi0
sio0: type 16550A
sio1 port 0x2f8-0x2ff irq 3 on acpi0
sio1: type 16550A
ppc0 port 0x778-0x77b,0x378-0x37f irq 7 drq 3 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/16 bytes threshold
ppbus0: <Parallel port bus> on ppc0
ppbus0: IEEE1284 device found /NIBBLE
Probing for PnP devices on ppbus0:
ppbus0: <Hewlett-Packard HP LaserJet 5L/0101.03> HP ENHANCED PCL5,PJL
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
orm0: <Option ROMs> at iomem 0xd8000-0xdffff,0xd4000-0xd7fff,0xcc000-0xd3fff,0xc0000-0xc8fff on isa0
pmtimer0 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
APIC_IO: Testing 8254 interrupt delivery
APIC_IO: routing 8254 via IOAPIC #0 intpin 2

Timecounters tick every 10.000 msec
acpi_cpu: throttling enabled, 2 steps (100% to 50.0%), currently 100.0%
GEOM: create disk ad0 dp=0xc6b2c370
ad0: 76319MB <ST380021A> [155061/16/63] at ata0-master UDMA100
acd0: DVDROM <CREATIVE DVD-ROM DVD6240E> at ata1-master PIO4
GEOM: create disk cd0 dp=0xc68d9e00
GEOM: create disk cd1 dp=0xc6916e00
pass0 at adv0 bus 0 target 2 lun 0
pass0: <HP C7670A 3925> Fixed Processor SCSI-2 device 
pass0: 3.300MB/s transfers
SMP: AP CPU #1 Launched!
cd0 at adv0 bus 0 target 4 lun 0
cd0: <PLEXTOR CD-R   PX-W1210S 1.00> Removable CD-ROM SCSI-2 device 
cd0: 10.000MB/s transfers (10.000MHz, offset 15)
cd0: Attempt to query device size failed: NOT READY, Medium not present - tray closed
cd1 at adv0 bus 0 target 6 lun 0
cd1: <PLEXTOR CD-ROM PX-32TS 1.02> Removable CD-ROM SCSI-2 device 
cd1: 10.000MB/s transfers (10.000MHz, offset 15)
cd1: Attempt to query device size failed: NOT READY, Medium not present
Mounting root from ufs:/dev/ad0s2a
WARNING: / was not properly dismounted
WARNING: /pack was not properly dismounted
WARNING: /tmp was not properly dismounted
WARNING: /usr was not properly dismounted
WARNING: /var was not properly dismounted
/var: mount pending error: blocks 12 files 3
WARNING: driver "rtc" used unreserved major device number 202
WARNING: driver "vmmon" used unreserved major device number 200
/dev/vmmon: Module vmmon: registered with major=200 minor=0 tag=$Name: build-570+ $
/dev/vmmon: Module vmmon: initialized
fxp0: promiscuous mode enabled
vmnet1: promiscuous mode enabled
drm0: <Matrox G550 (AGP)> mem 0xf7000000-0xf77fffff,0xf6000000-0xf6003fff,0xf4000000-0xf5ffffff irq 10 at device 0.0 on pci1
info: [drm] AGP at 0xf0000000 64MB
info: [drm] Initialized mga 3.1.0 20021029 on minor 0
drm0: [MPSAFE]


More information about the freebsd-current mailing list