kernel halts before booting

Andy Farkas andyf at speednet.com.au
Sat Nov 8 15:22:21 PST 2003


My kernels now break into the debugger before booting!

Boot sequence goes like this:

...
Hit [Enter] to boot immediately, or any other key for command prompt.
Booting [/boot/kernel/kernel]...
cpuid = 0; apic id = 00
instruction pointer     = 0x0:0xa00
stack pointer           = 0x0:0xffe
frame pointer           = 0x0:0x0
code segment            = base 0x0, limit 0x0, type 0x0
                        = DPL 0, pres 0, def32 0, gran 0
processor eflags        = interrupt enabled, vm86, IOPL = 0
current process         = 0 ()
kernel: type 30 trap, code=0
stopped at      0xa00:  cli
db> cont
Copyright (c) 1992-2003 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 5.1-CURRENT #0: Fri Nov  7 17:17:10 EST 2003
    root at team2.af.speednet.com.au:/usr/obj/usr/src/sys/TEAM2
Preloaded elf kernel "/boot/kernel/kernel" at 0xc0751000.
MPTable: <ASUSTEK0 P54NP4000000>
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Pentium/P54C (132.00-MHz 586-class CPU)
  Origin = "GenuineIntel"  Id = 0x52c  Stepping = 12
  Features=0x3bf<FPU,VME,DE,PSE,TSC,MSR,MCE,CX8,APIC>
real memory  = 134217728 (128 MB)
avail memory = 124928000 (119 MB)
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1
Intel Pentium detected, installing workaround for F00F bug
ioapic0: Assuming intbase of 0
ioapic0 <Version 1.1> irqs 0-15 on motherboard
    ACPI-0159: *** Error: AcpiLoadTables: Could not get RSDP, AE_NO_ACPI_TABLES
    ACPI-0213: *** Error: AcpiLoadTables: Could not load tables: AE_NO_ACPI_TABLES
ACPI: table load failed: AE_NO_ACPI_TABLES
npx0: [FAST]
...


Also happens with GENERIC.

--

 :{ andyf at speednet.com.au

        Andy Farkas
    System Administrator
   Speednet Communications
 http://www.speednet.com.au/




More information about the freebsd-current mailing list