new interrupt code? fwohci0 running wild

John Baldwin jhb at FreeBSD.org
Wed Nov 5 14:44:14 PST 2003


On 05-Nov-2003 Lars Eggert wrote:
> Hi,
> 
> just made and installed today's world, and while the system boots, 
> performance is sluggish. This is likely due to irq16/fwohci0, which 
> seems to run wild:
> 
> [root at nik: /] uptime && vmstat -i
> 11:21AM  up 9 mins, 3 users, load averages: 0.54, 0.71, 0.43
> interrupt                          total       rate
> irq6: fdc0                             4          0
> irq8: rtc                          72244        127
> irq13: npx0                            1          0
> irq14: ata0                         1868          3
> irq15: ata1                           97          0
> irq16: fwohci0                  50191801      88835
> irq17: em1                         24890         44
> irq18: pcm0                           25          0
> irq19: uhci0 bktr0                  4551          8
> irq20: mpt0                           46          0
> irq21: em0 mpt1                     8003         14
> irq0: clk                          56443         99
> Total                           50359973      89132
> 
> Nothing is plugged into the firewire port, if that matters. The machine 
> is an SMP box, dmesg and pciconf output are attached.
> 
> Please let me know what other information I can provide.

What happens if you kldunload the firewire driver?  Also, what happens
if you boot w/o it loaded in the first place?

-- 

John Baldwin <jhb at FreeBSD.org>  <><  http://www.FreeBSD.org/~jhb/
"Power Users Use the Power to Serve!"  -  http://www.FreeBSD.org/


More information about the freebsd-current mailing list