-current 'make release' status? [SOLVED]

Ruslan Ermilov ru at FreeBSD.org
Tue Jul 29 07:39:21 PDT 2003

On Tue, Jul 29, 2003 at 09:41:54AM -0400, John De Boskey wrote:
> ----- Ruslan Ermilov's Original Message -----
> > > 
> > > No, I have nothing in my environment that should affect the
> > > build, no /etc/make.conf in the chroot area..
> > > 
> > But then again: running "make rerelease" is effectively just
> > calls the command above.  I'm currently in the middle of the
> > "make release" and will see if this is reproduceable.
> > 
> > > # chroot /vol/vol0/work/5-current-chrootdir /bin/sh
> > > # env
> > > 
> > > A few things not needed that are inherited from my normal
> > > account, but nothing that should have a negative affect.
> > > 
> > Do you still get the error if you try "make rerelease"?
> > Do you still get the error if you try "chroot ... /mk"?
> > Do you still get the error if you try "env -i chroot ... /mk"?
> I'll see what I can find..

I see the same breakage as you do.  But in all three cases
above, I see the same breakage (as expected).  Even if I'm
running "chroot /data/ru/R" then "./mk doMFSKERN", I still
get it:

: In file included from /usr/src/sys/cam/cam_periph.c:41:
: /usr/src/sys/sys/buf.h: In function `BUF_LOCK':
: /usr/src/sys/sys/buf.h:289: warning: dereferencing type-punned pointer will break strict-aliasing rules
: ...
: *** Error code 1
: Stop in /usr/obj/usr/src/sys/BOOTMFS.

Forget what I've said about NO_WERROR, it (unfortunately) only
applies to the userland.

Still, running "make rerelease KERNEL_FLAGS=WERROR=" gets the
release done.

I wondered why I get it, and similarly my nigthly "buildkernel"
completed without errors.  This turned out to be due to the
-O vs. -Os differences.  For example, compiling vfs_subr.o
from the GENERIC kernel results in these same warnings when
compiled with COPTFLAGS="-Os -pipe".  Peter, should we switch
-Werror back off in kern.pre.mk?

Ruslan Ermilov		Sysadmin and DBA,
ru at sunbay.com		Sunbay Software Ltd,
ru at FreeBSD.org		FreeBSD committer
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-current/attachments/20030729/ab242f0a/attachment.bin

More information about the freebsd-current mailing list