Keyboard not working with XFree86

Daniel Lang dl at
Wed Jul 16 08:16:26 PDT 2003

Hi Folks,

I've recently upgraded my Notebook to 5.1-CURRENT.
One of the main problems I ran into, is, that the
keyboard is not working when using X.

For the update from 4.8 to 5.1 I've followed the
UPDATING procedure and was successful. After that
I deleted all ports/packages and installed most of the
ports fresh, including XFree86.
Now I have XFree86-Server-4.3.0_8 installed.

If I start up X, I cannot put in any key. The mouse works
fine, though. I have to remote log into the box and kill
xdm to get rid of the problem.

The keyboard works perfectly on the console.

I searched the mailing list archives and bug reports, but
did not find anything.

I also tried to create a fresh XF86Config file using
xf86cfg (GUI based) and xf86config (text based).
Both resulting config files had the same problem as the 
original config file, i.e. everything works except the

Now I've updated my 5.1-CURRENT to a snapshot from July 15,
and tried to rebuild the XFree86-4-Server port.

Now, the portbuild fails in 


while trying to compile "radeon_vtxtmp_x86.S"

error message are many lines of similar output, example:
radeon_vtxtmp_x86.S:400:34: pasting "_x86_MultiTexCoord2fARB_2" and ":"
does not give a valid preprocessing token.

I don't think thats a problem, but due to the recent gcc import,
since the portrevision has not changed, this probably wouldn't
solve my problem anyway.

But for the keyboard problem, any hints are appreciated.

Best regards,
IRCnet: Mr-Spock   - signs of absurd developments in the net community: 
#42:   - "Wurstbrot gehoert m.E. zum Fruehstuecks-botnet von Cartoon" -  
 Daniel Lang * dl at * +49 89 289 18532 *
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 6020 bytes
Desc: not available
Url :

More information about the freebsd-current mailing list