usb mouse on ehci controller doesn't work

Doug White dwhite at
Tue Jul 8 00:03:37 PDT 2003

On Mon, 7 Jul 2003, Doug White wrote:

> On Sun, 6 Jul 2003, Bruce Cran wrote:
> > I swapped the Logitech wireless mouse for a Microsoft Intellimouse optical,
> > and this time had slightly more success.   If I run moused and tell XFree86
> > to use both /dev/psm0 and /dev/sysmouse, it still dies with the fcntl error.
> > However, if I'm only using /dev/sysmouse, it works perfectly.  The kernel has
> > uhci but not ehci compiled in, so it must indeed be using the low-speed
> > driver, not ehci.  If I don't run moused but just tell X11 to use /dev/ums0,
> > it still fails with the fcntl error.
> Hm, well it appears that psm and ums have lost their O_ASYNC handlers.
> I'm using moused and it works fine, but I think I know who to pummel.

You know, I just tried this on my -current box with XFree86 4.3 and it
works fine regardless of the warning.  Are you sure XFree86 is dying due
to the mouse problem, or something else?

All I did was flip the device from /dev/sysmouse to /dev/ums0.

Doug White                    |  FreeBSD: The Power to Serve
dwhite at          |

More information about the freebsd-current mailing list