WLAN card not working anymore

Harti Brandt brandt at fokus.fraunhofer.de
Thu Jul 3 07:32:16 PDT 2003


On Thu, 3 Jul 2003, Oliver Brandmueller wrote:

OB>Hi.
OB>
OB>On Thu, Jul 03, 2003 at 01:39:19PM +0200, Harti Brandt wrote:
OB>> Jul  3 09:18:29 harti kernel: wi0: Lucent Firmware: Station (7.52.1)
OB>
OB>Well, I'm still seeing problems with my Lucent Card on -CURRENT (there
OB>were postings here about that earlier, but Ican't provide details at the
OB>moment as I don't have time to test - sorry Sam, Warner).
OB>
OB>Maybe you should try updating to the latest Firmware of the card, which
OB>is 8.10.1 at Lucent. That fixed a lot of problems for a friend of mine
OB>(at least under -STABLE some time ago). As soon as you have the latest
OB>Station Firmware in the card rerun your tests.

Took me a while to find the firmware. I finally managed to find it at
www.agere.com. Updating to 8.72.1 seems to cure the problem. There are
only two messages left that seem to be harmless:

  Jul  3 16:08:59 harti kernel: wi0: <Avaya Communication Avaya Wireless PC Card> at port 0x100-0x13f irq 11 function 0 config 1 on pccard0
  Jul  3 16:08:59 harti kernel: wi0: 802.11 address: 00:02:2d:42:a2:d7
  Jul  3 16:08:59 harti kernel: wi0: using Lucent Technologies, WaveLAN/IEEE
  Jul  3 16:08:59 harti kernel: wi0: Lucent Firmware: Station (8.72.1)
  Jul  3 16:08:59 harti kernel: wi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
! Jul  3 16:09:05 harti kernel: wi0: bad alloc 204 != 201, cur 0 nxt 0
  Jul  3 16:09:09 harti dhclient: New Network Number: 195.37.78.0
  Jul  3 16:09:09 harti dhclient: New Broadcast Address: 195.37.78.255
! Jul  3 16:09:09 harti kernel: wi0: bad alloc 208 != 205, cur 0 nxt 0

Thanks,
harti
-- 
harti brandt,
http://www.fokus.fraunhofer.de/research/cc/cats/employees/hartmut.brandt/private
brandt at fokus.fraunhofer.de, harti at freebsd.org


More information about the freebsd-current mailing list