should fdisk -BI still work?

John Hay jhay at
Wed Jul 2 06:54:09 PDT 2003

On Tue, Jul 01, 2003 at 08:20:11AM -0700, Brooks Davis wrote:
> On Tue, Jul 01, 2003 at 11:15:49AM +0200, John Hay wrote:
> > Hi,
> > 
> > Should "fdisk -BI ad0" still work on current? I have a script that I use
> > to prepare flash disks that have worked for a long time on older versions
> > of FreeBSD, but it seems a little broken on -current. It actually started
> > with the one from Warner's site people.../~imp/ and tweaked it
> > over time to keep it running.
> > 
> > On current I get an error when doing "fdisk -BI ad0":
> > 
> > fdisk: invalid fdisk partition table found
> > 
> > So how is one supposed to create a FreeBSD slice nowadays from a script?
> I'm not using -BI, but I am using -I in a version of diskprep.   Are you
> sure you don't have any slices (or partitions inside those slices) open?
> I remember getting all sorts of weird errors when I forgot about that
> while developing my new scripts.

Sorry guys, false alarm. There was something wrong with that flash disk.
It probed ok, but ignored writes to the first sector. :-/ I tried with
a different one and it is working now.

John Hay -- John.Hay at / jhay at

More information about the freebsd-current mailing list