[Bug 236233] Python multiprocessing is 20x slower with 11.2 compared to 11.0 kernel

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Mon Mar 4 22:07:57 UTC 2019


            Bug ID: 236233
           Summary: Python multiprocessing is 20x slower with 11.2
                    compared to 11.0 kernel
           Product: Base System
           Version: 11.2-RELEASE
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: kern
          Assignee: bugs at FreeBSD.org
          Reporter: arichardson at FreeBSD.org

After I updated our jenkins slaves from 11.0 to 11.2 running the LLVM
regression test suite takes over 2 hours instead of 5-10 minutes.
The testsuite is driven by llvm-lit (a python script) that makes heavy use of
python multiprocessing module.

On 11.0 the test output prints status updates all the time whereas on 11.2 it
will print N (or N-1, N-2) status updates (with N being the number of parallel
jobs) before a noticeable pause. In that pause it seems like the individual
python processes start using 100% CPU.

I tried updating one of the slaves to 12.0 but it is still just as slow.

I also tried updating python27 to the latest 11.2 package (2.7.15) but that
still runs fast. Therefore it seems to me like this could be a regression with
semaphores or umtx.
I am also not sure if this is a regression in the kernel or libc/libthr.

Downgrading to 11.0 fixes the issue.

You are receiving this mail because:
You are the assignee for the bug.

More information about the freebsd-bugs mailing list