[Bug 151910] [zfs] booting from raidz/raidz2 on ciss(4) doesn't work

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Tue May 22 07:43:37 UTC 2018


https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=151910

Kazuhiko Kiriyama <kiri at kx.openedu.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |kiri at kx.openedu.org

--- Comment #13 from Kazuhiko Kiriyama <kiri at kx.openedu.org> ---
Same issue occered in 12.0-CURRENT(r332796) on 2 RAID controllers. One is
RAID60 of 2TB SATA (HGST AUG-2017) x 12 on AVAGO MegaRAID and the other is
RAID60 of 2TB SATA (WD20EFRX) x 12 on Adaptec 5405.  For MegaRAID machine:

# dmesg
  :
pci1: <ACPI PCI bus> on pcib1
AVAGO MegaRAID SAS FreeBSD mrsas driver version: 06.712.04.00-fbsd
mfi0: <Invader> port 0xe000-0xe0ff mem
0xdf300000-0xdf30ffff,0xdf200000-0xdf2fffff irq 16 at device 0.0 on pci1
mfi0: Using MSI
mfi0: Megaraid SAS driver Ver 4.23 
  :
mfid0 on mfi0
mfid0: 15257600MB (31247564800 sectors) RAID volume 'TrueFC' is optimal
  :
# diskinfo -v mfid0
mfid0
        512             # sectorsize
        15998753177600  # mediasize in bytes (15T)
        31247564800     # mediasize in sectors
        0               # stripesize
        0               # stripeoffset
        1945070         # Cylinders according to firmware.
        255             # Heads according to firmware.
        63              # Sectors according to firmware.
                        # Disk descr.
                        # Disk ident.
        No              # TRIM/UNMAP support
        Unknown         # Rotation rate in RPM

# camcontrol devlist -v
scbus0 on ahcich0 bus 0:
<>                                 at scbus0 target -1 lun ffffffff ()
scbus1 on ahcich1 bus 0:
<>                                 at scbus1 target -1 lun ffffffff ()
scbus2 on ahcich2 bus 0:
<>                                 at scbus2 target -1 lun ffffffff ()
scbus3 on ahcich3 bus 0:
<>                                 at scbus3 target -1 lun ffffffff ()
scbus4 on ahcich4 bus 0:
<>                                 at scbus4 target -1 lun ffffffff ()
scbus5 on ahcich5 bus 0:
<>                                 at scbus5 target -1 lun ffffffff ()
scbus6 on ahciem0 bus 0:
<AHCI SGPIO Enclosure 1.00 0001>   at scbus6 target 0 lun 0 (pass0,ses0)
<>                                 at scbus6 target -1 lun ffffffff ()
scbus7 on umass-sim0 bus 0:
<A-DATA USB Flash Drive 0.00>      at scbus7 target 0 lun 0 (da0,pass1)
scbus-1 on xpt0 bus 0:
<>                                 at scbus-1 target -1 lun ffffffff (xpt0)
# pciconf -lv
  :
mfi0 at pci0:1:0:0:        class=0x010400 card=0x93631000 chip=0x005d1000 rev=0x02
hdr=0x00
    vendor     = 'LSI Logic / Symbios Logic'
    device     = 'MegaRAID SAS-3 3108 [Invader]'
    class      = mass storage
    subclass   = RAID
  :
# gpart show mfid0
=>         40  31247564720  mfid0  GPT  (15T)
           40         1024      1  freebsd-boot  (512K)
         1064          984         - free -  (492K)
         2048    268435456      2  freebsd-swap  (128G)
    268437504  30979125248      3  freebsd-zfs  (14T)
  31247562752         2008         - free -  (1.0M)

# kldload zfs
# zpool import -fR /mnt zroot
# zpool status 
  pool: zroot
 state: ONLINE
  scan: none requested
config:

        NAME        STATE     READ WRITE CKSUM
        zroot       ONLINE       0     0     0
          mfid0p3   ONLINE       0     0     0

errors: No known data errors
#

-- 
You are receiving this mail because:
You are the assignee for the bug.


More information about the freebsd-bugs mailing list