[Bug 228123] date command gives wrong time when used in tcsh aliases

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Thu May 10 17:24:47 UTC 2018


            Bug ID: 228123
           Summary: date command gives wrong time when used in tcsh
           Product: Base System
           Version: 11.1-RELEASE
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: misc
          Assignee: bugs at FreeBSD.org
          Reporter: allcoms at gmail.com

I am running a fully up to date FreeBSD 11.1-RELEASE-p10 / amd64 and I am using
tcsh for my shell. I created a couple of aliases to create date and timestamped
ZFS snapshots and added them to my ~/.cshrc but the time output by my custom
`date` format command is always behind the actual time. If I run my aliases
straight after booting, they are only about 1m behind but the longer my machine
is turned on, the more the time in the aliases gets out of sync with the actual

If I run just `date` or if I run the date command using my formatted output
from the command line, I get the correct time. It is only when date is executed
via my aliases that the time falls behind.

One of my aliases that exhibits this issue:

alias zsd        sudo zfs snapshot -r data/media@`date +%d-%m-%Y-%T`

You are receiving this mail because:
You are the assignee for the bug.

More information about the freebsd-bugs mailing list