[Bug 210683] [iscsi] FreeBSD panics almost immediately after starting ctld

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Wed Jun 29 06:59:32 UTC 2016


https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=210683

            Bug ID: 210683
           Summary: [iscsi] FreeBSD panics almost immediately after
                    starting ctld
           Product: Base System
           Version: 11.0-CURRENT
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: kern
          Assignee: freebsd-bugs at FreeBSD.org
          Reporter: emz at norma.perm.ru

FreeBSD panics almost immidiately after starting ctld.

FreeBSD holds 24 disks for VM resources, which are organized on zfs pools;
zvols are created which are distributed via iSCSI. FreeBSD was up for several
days, and then (all of a sudden, after some good production use) this panic
appeared.

Panic screen is attached.
Panic is 100% reproducible after rebooting.

I can also provide the direct server access if needed.

Disks:
===Cut===
[root at san1:~]# camcontrol devlist 
<LSI SAS3x40 0601>                 at scbus1 target 4 lun 0 (pass0,ses0)
<ATA INTEL SSDSC2BW24 RG21>        at scbus1 target 5 lun 0 (pass1,da0)
<ATA ST2000NX0253 SN02>            at scbus1 target 6 lun 0 (pass2,da1)
<ATA ST2000NX0253 SN02>            at scbus1 target 7 lun 0 (pass3,da2)
<ATA ST2000NX0253 SN02>            at scbus1 target 8 lun 0 (pass4,da3)
<ATA ST2000NX0253 SN02>            at scbus1 target 9 lun 0 (pass5,da4)
<ATA ST2000NX0253 SN02>            at scbus1 target 10 lun 0 (pass6,da5)
<ATA ST2000NX0253 SN02>            at scbus1 target 11 lun 0 (pass7,da6)
<ATA ST2000NX0253 SN02>            at scbus1 target 12 lun 0 (pass8,da7)
<ATA ST2000NX0253 SN02>            at scbus1 target 13 lun 0 (pass9,da8)
<ATA ST2000NX0253 SN02>            at scbus1 target 14 lun 0 (pass10,da9)
<ATA ST2000NX0253 SN02>            at scbus1 target 15 lun 0 (pass11,da10)
<ATA ST2000NX0253 SN02>            at scbus1 target 16 lun 0 (pass12,da11)
<ATA ST2000NX0253 SN02>            at scbus1 target 17 lun 0 (pass13,da12)
<ATA ST2000NX0253 SN02>            at scbus1 target 18 lun 0 (pass14,da13)
<ATA ST2000NX0253 SN02>            at scbus1 target 19 lun 0 (pass15,da14)
<ATA ST2000NX0253 SN02>            at scbus1 target 20 lun 0 (pass16,da15)
<ATA ST2000NX0253 SN02>            at scbus1 target 21 lun 0 (pass17,da16)
<ATA INTEL SSDSC2BW24 RG21>        at scbus1 target 22 lun 0 (pass18,da17)
<ATA INTEL SSDSC2BW24 RG21>        at scbus1 target 23 lun 0 (pass19,da18)
<ATA INTEL SSDSC2BW24 RG21>        at scbus1 target 24 lun 0 (pass20,da19)
<ATA INTEL SSDSC2BW24 RG21>        at scbus1 target 25 lun 0 (pass21,da20)
<ATA INTEL SSDSC2BW24 RG21>        at scbus1 target 26 lun 0 (pass22,da21)
<ATA INTEL SSDSC2BW24 RG21>        at scbus1 target 27 lun 0 (pass23,da22)
<ATA INTEL SSDSC2BW24 RG21>        at scbus1 target 28 lun 0 (pass24,da23)
<AHCI SGPIO Enclosure 1.00 0001>   at scbus6 target 0 lun 0 (pass25,ses1)
<AHCI SGPIO Enclosure 1.00 0001>   at scbus13 target 0 lun 0 (pass26,ses2)
===Cut===

Controller:
===Cut===
# MegaCli -CfgDsply -aAll

==============================================================================
Adapter: 0
Product Name: LSI MegaRAID SAS 9341-4i
Memory: 0MB
BBU: Absent
Serial No: SV62122829
==============================================================================
Number of DISK GROUPS: 0


Exit Code: 0x00
===Cut===

disks are used in JBOD/Passthrough mode.
I have a dumpdev configured, but savecore sayd there's no core. Either my swap
device is smaller, or there's just no core.

-- 
You are receiving this mail because:
You are the assignee for the bug.


More information about the freebsd-bugs mailing list