[Bug 206599] Geli restore from backuped geli-metadata is not possible

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Mon Jan 25 11:08:26 UTC 2016


https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=206599

            Bug ID: 206599
           Summary: Geli restore from backuped geli-metadata is not
                    possible
           Product: Base System
           Version: 10.2-STABLE
          Hardware: amd64
                OS: Any
            Status: New
          Severity: Affects Some People
          Priority: ---
         Component: kern
          Assignee: freebsd-bugs at FreeBSD.org
          Reporter: marc.arnold.bach at gmail.com
                CC: freebsd-amd64 at FreeBSD.org
                CC: freebsd-amd64 at FreeBSD.org

Hello,

Setup:
- I installed a freebsd in a vmware from using "auto zfs root" option.
- The zroot pool is located on /dev/da0p4.eli after installation. 
- Rebooting works, even if keyboardlayout during boot is US not selected...
(this is a simple setting..)

Symptom:
Restoring a metadata from file is rejected by geli

Procedure to reproduce this:

root# geli backup /dev/da0p4 /root/backupme
root# geli restore /root/backupme /dev/da0p4
geli: Cannot write metadata to /dev/da0p4: Operation not permitted


Some tests I did:
a)
file backupme is existing and has size 512byte... For testing I tried to
restore it to the created blockdevice da0p4.eli. The application rejects due to
size, what makes sense as this is the inner container, not the partition
itself.
=> file seems to contain valid data

b) I tried to force restoring to /dev/da0p4, even if partition was never
modified.. same result: Operation not permitted...

The zpool was not exported, nor the cryptodevice detached as it is the
rootpool. However it is never mentioned that restore works only in detached,
offline blockdevices... it is just a block of data at the end with same
masterpwd...

Regards Marc

-- 
You are receiving this mail because:
You are the assignee for the bug.


More information about the freebsd-bugs mailing list