[Bug 206296] mt - write protect is not reported in status

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Fri Jan 15 20:58:29 UTC 2016


https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=206296

            Bug ID: 206296
           Summary: mt - write protect is not reported in status
           Product: Base System
           Version: 10.2-RELEASE
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Some People
          Priority: ---
         Component: misc
          Assignee: freebsd-bugs at FreeBSD.org
          Reporter: andrew at grillet.co.uk

The mt command does not show the "write protect" status of a tape. This would
presumably apply to other devices that support write protection, but I cannot
test for that. 

You cannot write to write protected tapes (see BID9933), and get an error if
you try - but it is very hard to find the error message if you tar to a write
protected tape using a remote login, and if you use a changer remotely, this is
seriously hard to debug! 

So two bugs (possibly feature requests):

1) mt -f /dev/sa0 status
# Should report "Write protected" or "Write enabled" as appropriate
# I tried to implement this myself, but I think it might be easier for someone
else to do it!

2) tar c -f /dev/sa0 file
# should write "Error: target is Write protected" to stderr
# which presumably requires significant design effort, as both cam and tar
# would need changes.

-- 
You are receiving this mail because:
You are the assignee for the bug.


More information about the freebsd-bugs mailing list