[Bug 200526] [snd_hda] hissing/static noise from headphone jack on Dell Precision M4800

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Fri May 29 21:15:06 UTC 2015


            Bug ID: 200526
           Summary: [snd_hda] hissing/static noise from headphone jack on
                    Dell Precision M4800
           Product: Base System
           Version: 10.1-STABLE
          Hardware: amd64
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: kern
          Assignee: freebsd-bugs at FreeBSD.org
          Reporter: david at catwhisker.org

Several weeks ago, I replaced my Dell Precision M440 laptop with a new M4800. 
Sound had "just worked" on the M4400; I was, therefore, rather surprised when I
found the hissing/static noise cited in the summary (after swapping the drive
from the M4400 into the M4800).

I posted about this on a Dell forum (as I wanted to have some way of
determining whether this might be a hardware issue (e.g., flaky ground
connection or something similar); ref.
<http://en.community.dell.com/support-forums/laptop/f/3517/t/19628711> for that
thread.  As noted there, I found that the objectionable sound in question is
not present (and sound appears to work OK) when the machine runs MS Windows.  I
believe that this implies that the observed problem is not because of a
hardware issue.

I also posted about the issue in freebsd-multimedia@; ref.
<http://docs.FreeBSD.org/cgi/mid.cgi?20150416173126.GG36163> for the start of
that thread.

I have also found that if I boot Fedora 20 or 21, sound works as expected (no
hissing); trying Fedora 19, there is no sound at all.

<http://www.catwhisker.org/~david/FreeBSD/m4800/hda.txt> has the "hda" and
"pcm" parts of a verbose dmesg.boot; I have placed several other
possibly-useful (and -relevant) files in the same directory
(<http://www.catwhisker.org/~david/FreeBSD/m4800/>), including dmesg and output
from the "ALSA Information Script" from testing Fedora 21.

The effect appears to be the same whether I run i386 or amd64, and whether I
run stable/10 or head.  (I track each of those four combinations daily, and
capture a verbose dmesg.boot for each.)

I will be happy to hack & test, but I need some guidance.

You are receiving this mail because:
You are the assignee for the bug.

More information about the freebsd-bugs mailing list