[Bug 199863] kernel panic (ufs_dirrem) using portmaster

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Sat May 2 12:50:49 UTC 2015


https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=199863

            Bug ID: 199863
           Summary: kernel panic (ufs_dirrem) using portmaster
           Product: Base System
           Version: 10.1-STABLE
          Hardware: amd64
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: kern
          Assignee: freebsd-bugs at FreeBSD.org
          Reporter: trust_no_1 at libero.it

Created attachment 156236
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=156236&action=edit
core file for kernel panic

On my system I have installed dns/bind99 configured with a fake domain (2mh.it)
for learning purposes.
As far as I can tell all works well, and I can surf the web, ping external
hosts and so on without problems.

=> Trying to update dns/bind it via "portmaster -B bind" to the latest version,
leads to a kernel panic <=

What I have done is simply to run (as root):
1) portsnap fetch update
2) portmaster -B bind

After 2), the build starts and all things go well until the script try to
delete the old files,... then suddenly the kernel panics.
I tough the problem could be related to my raid card, so I tried to disable the
write cache from the controller bios and redo 1) and 2), but noting changed.

I also tried to mount both /var and /usr as readonly, then "tunefs -j disable
-n disable" for the two filesystems and "rm .sujournal" on them.
Then re-enable both journal and softupdates, and remount as rw /var and /usr
and again 1) and 2)
But noting changed, all the times I have the same panic at the same point.
I attach the core file.
Thank yopu.

-- 
You are receiving this mail because:
You are the assignee for the bug.


More information about the freebsd-bugs mailing list