[Bug 193743] RTL8111/8168B PCI Express Gigabit Ethernet controller: doesn't work properly, problems getting UP automatically

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Thu Sep 18 10:57:01 UTC 2014


--- Comment #1 from Guido Falsi <madpilot at FreeBSD.org> ---
I reported a similar issue some time ago, this is the relevant thread on
net at FreeBSD.org:


Some patches were tried at the time but the problem was not solved.

I'm currently working around this with a startup script doing:

start_cmd="ifconfig ${refix_if} tso"

(tso is already on by default, just touching the flag wakes up the adapter).

My machine is a Fujitsu siemens tower Esprimo PH300 E85+.

pciconf -lbcev:

re0 at pci0:3:0:0: class=0x020000 card=0x11c01734 chip=0x816810ec rev=0x07
    vendor     = 'Realtek Semiconductor Co., Ltd.'
    device     = 'RTL8111/8168B PCI Express Gigabit Ethernet controller'
    class      = network
    subclass   = ethernet
    bar   [10] = type I/O Port, range 32, base 0xd000, size 256, enabled
    bar   [18] = type Prefetchable Memory, range 64, base 0xf2104000, size
4096, enabled
    bar   [20] = type Prefetchable Memory, range 64, base 0xf2100000, size
16384, enabled
    cap 01[40] = powerspec 3  supports D0 D1 D2 D3  current D0
    cap 05[50] = MSI supports 1 message, 64 bit 
    cap 10[70] = PCI-Express 2 endpoint IRQ 1 max data 128(128) link x1(x1)
                 speed 2.5(2.5) ASPM disabled(L0s/L1)
    cap 11[b0] = MSI-X supports 4 messages, enabled
                 Table in map 0x20[0x0], PBA in map 0x20[0x800]
    cap 03[d0] = VPD
    ecap 0001[100] = AER 1 0 fatal 0 non-fatal 1 corrected
    ecap 0002[140] = VC 1 max VC0
    ecap 0003[160] = Serial 1 0100000004000001
  PCI-e errors = Correctable Error Detected
                 Unsupported Request Detected
     Corrected = Advisory Non-Fatal Error

You are receiving this mail because:
You are the assignee for the bug.

More information about the freebsd-bugs mailing list