[Bug 193228] freebsd-update(8) -b for jail updates fails on last "install" within major-update

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Mon Sep 1 17:34:48 UTC 2014


Martin Kropfinger <freebsdbugzilla at schreibteinemail.de> changed:

           What    |Removed                     |Added
            Summary|freebsd-update(8) for       |freebsd-update(8) -b for
                   |jailupdates                 |jail updates fails on last
                   |                            |"install" within
                   |                            |major-update

--- Comment #1 from Martin Kropfinger <freebsdbugzilla at schreibteinemail.de> ---
Updating a jails, for patch levels, can be done with freebsd-update(8). I tried
updating a jail with freebsd-update from 9.2-p10 to 10.0-p7.

At first i set UNAME_r using setenv to 9.2-RELEASE-p10 and did the:

freebsd-update upgrade -r 10.0-RELEASE -b /usr/jails/wiki

Followed by freebsd-update install and again freebsd-update install. During
this I restarted the jail.

After this I rebuild all ports inside the jail. At last I tried the last
freebsd-install with:
freebsd-update upgrade -r 10.0-RELEASE -b /usr/jails/wiki

freebsd-install(8) returned:

Installing updates...rmdir: /usr/jails/wiki//var/named/etc/namedb/master:
Directory not empty
rmdir: /usr/jails/wiki//var/named/etc/namedb: Directory not empty
rmdir: /usr/jails/wiki//var/named/etc: Directory not empty
rmdir: /usr/jails/wiki//var/named: Directory not empty

So the paths seem to be handled in a wrong way.

The jail can't be started at all because oh wrong libs.

You are receiving this mail because:
You are the assignee for the bug.

More information about the freebsd-bugs mailing list