[Bug 195458] Hang on shutdown/root unmount after FreeBSD 10.1R upgrade

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Sat Nov 29 22:38:48 UTC 2014


https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=195458

--- Comment #1 from Walter Hop <walter at lifeforms.nl> ---
I noticed today that the same problem happens when upgrading from 10.1-RC3 to
10.1-RELEASE, and also on a clean install of 10.1-RELEASE.

I did some more digging. As a refresher, the hang didn't occur just when
booting the new kernel. It happened only after "freebsd-update install" was
executed to replace userland. What is so special about "freebsd-update install"
that would trigger the problem?

I think the interesting bit might be that it replaced /sbin/init.

I can completely reliably trigger a hang on a default 10.1-RELEASE install on
UFS2 in VMware Fusion with the following procedure:

# chflags noschg /sbin/init
# cp -Rp /sbin/init /sbin/init2
# rm -f /sbin/init
# mv /sbin/init2 /sbin/init
# chflags schg /sbin/init
# reboot
=> Hang after "All buffers synced."

I created two clean 10.1 UFS2 installs which both exhibit the problem 100% of
trying.

I tried doing the same on two clean 10.1 ZFS (auto) installs. ZFS does NOT
exhibit the problem so far.

I tried disabling softupdates (tunefs -n disable /dev/da0p2) before doing the
procedure. In this case, on multiple machines, it also does NOT hang.

On 10.0 there's also no problem.

So: on FreeBSD 10.1, when using UFS2 with journaled softupdates, replacing init
leads to a hang when rebooting/unmounting root afterwards.

And a workaround might be to disable softupdates before upgrading to 10.1.

-- 
You are receiving this mail because:
You are the assignee for the bug.


More information about the freebsd-bugs mailing list