[Bug 195090] New: /usr/bin/ld: cannot find -lstdc++ - Postgis / geos Error on install..

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Mon Nov 17 01:50:45 UTC 2014


            Bug ID: 195090
           Summary: /usr/bin/ld: cannot find -lstdc++ -  Postgis / geos
                    Error on install..
           Product: Base System
           Version: 10.1-STABLE
          Hardware: i386
                OS: Any
            Status: Needs Triage
          Severity: Affects Many People
          Priority: ---
         Component: misc
          Assignee: freebsd-bugs at FreeBSD.org
          Reporter: martin at marketbridge.com


Go easy on me here - first time reporting what looks like a bug.  I was on 9.1
and had a disaster hardware crash (2 drives - what luck - in RAID 5).  Anyhow,
my data was backed up.  I reinstalled 9.1 from CD but had issues with
re-installing Postgis and Geos.  So I upgraded (might as well) to 10.1 release
but still get the issue below.  I tried compiling Geos pkg from source (no
luck).  It's the gcc linker that keeps complaining about the lstdc++ library
not being there and it is correct.  If I look in /usr/bin, I do not see that
library. ???

Any help is appreciated.

om.a geomgraph/.libs/libgeomgraph.a index/.libs/libindex.a io/.libs/libio.a
linearref/.libs/liblinearref.a noding/.libs/libnoding.a
operation/.libs/liboperation.a planargraph/.libs/libplanargraph.a
precision/.libs/libprecision.a simplify/.libs/libsimplify.a
triangulate/.libs/libtriangulate.a util/.libs/libutil.a -Wl,--no-whole-archive
-L/usr/lib -lstdc++ -lm -lc -lgcc_s /usr/lib/crtendS.o /usr/lib/crtn.o
-Wl,-soname -Wl,libgeos-3.4.2.so -o .libs/libgeos-3.4.2.so

/usr/bin/ld: cannot find -lstdc++

c++: error: linker command failed with exit code 1 (use -v to see invocation)
gmake[7]: *** [libgeos.la] Error 1

You are receiving this mail because:
You are the assignee for the bug.

More information about the freebsd-bugs mailing list