misc/189849: Upgrade of newlisp to 10.6.0 fails

Jens Jahnke jan0sch at gmx.net
Fri May 16 06:50:00 UTC 2014


>Number:         189849
>Category:       misc
>Synopsis:       Upgrade of newlisp to 10.6.0 fails
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Fri May 16 06:50:00 UTC 2014
>Closed-Date:
>Last-Modified:
>Originator:     Jens Jahnke
>Release:        8.4
>Organization:
>Environment:
FreeBSD waltam.wegtam.com 8.4-RELEASE-p9 FreeBSD 8.4-RELEASE-p9 #0: Tue Apr 29 20:55:53 UTC 2014     root at amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64

>Description:
If I try to compile the newlisp 1.6.0 package, I get the following error:

cc -O2 -pipe -I/usr/local/include -DNEWLISP64 -fno-strict-aliasing  -m64 -c -DREADLINE -DNEWLISP64 -DSUPPORT_UTF8 -D_BSD -DFFI nl-sock.c
newlisp.c: In function 'main':
newlisp.c:907: error: 'CPPFunction' undeclared (first use in this function)
newlisp.c:907: error: (Each undeclared identifier is reported only once
newlisp.c:907: error: for each function it appears in.)
newlisp.c:907: error: expected expression before ')' token
newlisp.c: In function 'newlisp_completion':
newlisp.c:995: error: 'CPFunction' undeclared (first use in this function)
newlisp.c:995: error: expected expression before ')' token
*** Error code 1
1 error
*** Error code 2
1 error
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop in /usr/ports/lang/newlisp.
*** Error code 1

Stop in /usr/ports/lang/newlisp.

>How-To-Repeat:
Enable the following options and try to compile newlisp 10.6.0:
* GMP
* GSL
* MYSQL
* PGSQL
* SQLITE

I've tested on 8.4 and 9.2.
>Fix:


>Release-Note:
>Audit-Trail:
>Unformatted:


More information about the freebsd-bugs mailing list