conf/189605: After converting 9-stable to new pkg tools, periodic/weekly/400.status-pkg does not work anymore

Christoph Sold freebsd at cheasy.de
Sat May 10 14:50:01 UTC 2014


>Number:         189605
>Category:       conf
>Synopsis:       After converting 9-stable to new pkg tools, periodic/weekly/400.status-pkg does not work anymore
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Sat May 10 14:50:00 UTC 2014
>Closed-Date:
>Last-Modified:
>Originator:     Christoph Sold
>Release:        9.2-STABLE-20140502 FreeBSD
>Organization:
>Environment:
FreeBSD [---] 9.2-STABLE-20140502 FreeBSD 9.2-STABLE-20140502 #9 r265219: Fri May  2 15:54:17 UTC 2014     root@[---]:/usr/obj/usr/src/sys/GENERIC  amd64
>Description:
After converting 9-Stable to new pkg tools, periodic script 400.status-pkg still references old pkg tools. This results in loads of error messages mailed weekly to root.
>How-To-Repeat:
Convert 9-Stable to new pkg tools, enable the 400.pkg-status script in /etc/periodic.conf
>Fix:
Workaround:
disable 400.status-pkg

Fix:
Backport 400.status-pkg from HEAD, possibly with a test if the old or the new version should be used.

>Release-Note:
>Audit-Trail:
>Unformatted:


More information about the freebsd-bugs mailing list