[Bug 195744] New: Unable to boot FreeBSD 10.1 memstick image; readin failed

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Sat Dec 6 14:23:31 UTC 2014


            Bug ID: 195744
           Summary: Unable to boot FreeBSD 10.1 memstick image; readin
           Product: Base System
           Version: 10.1-RELEASE
          Hardware: amd64
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: kern
          Assignee: freebsd-bugs at FreeBSD.org
          Reporter: applepuffs1211 at gmail.com

Created attachment 150266
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=150266&action=edit
Screen output when booting FreeBSD memstick image

I can't boot FreeBSD memstick image from USB. The boot menu can display
successfully but then fail to boot.

Tried to use other image including :
1. FreeBSD-10.1-RELEASE-amd64-memstick.img
2. FreeBSD-10.1-RELEASE-amd64-mini-memstick.img
3. FreeBSD-10.1-RELEASE-amd64-uefi-memstick.img
4. FreeBSD-10.1-RELEASE-amd64-uefi-mini-memstick.img

And tried to use other USB storage device including :
1. TDK 8GB Flash Drive
2. WD MyPassport 500GB HDD
3. USB card reader with 2GB NOKIA mini-SD card

Computer :
*** ASUS ChromeBox M004U ( CN60 ) ***
CPU : Celeron 2955U 1.4GHz
RAM : 8GB ( 4GB X2 ; 1.35V ; DDR3 ; Crucial )
SSD : Transcend 128 GB SATA III 6Gb/s MTS400

All memstick image has tested with md5 and sha256sum.

Tried to use DD on Linux and win32imagewriter on Windows to create the USB
drive, but neither of them works.

Linux including Fedora/Ubuntu/OpenSUSE can boot and install successfully on
this machine. Not sure why FreeBSD is unable to boot.

Screenshot attached for reference.

--------------- Output of the screen --------------------

/boot/kernel/kernel text=0xf8f898
readin failed

elf64_loadimage: read failed
can't load file '/boot/kernel/kernel': input/output error
Error while including /boot/menu.rc, in the line:
Hit [Enter] to boot immediately, or any other key for command prompt.
Booting [/boot/kernel/kernel]...
/boot/kernel/kernel text=0xf8f898
readin failed
can't load 'kernel'

Type '?' for a list of commands, 'help' for more detailed help


------ Command used to copy image to usb drive ---------
umount /dev/sdc
umount /dev/sdc4
dd if=FreeBSD-10.1-RELEASE-amd64-memstick.img of=/dev/sdc bs=64k

------------------ Sha256sum of image ------------------

You are receiving this mail because:
You are the assignee for the bug.

More information about the freebsd-bugs mailing list